it-swarm.com.de

Ubuntu 12.04.5 LTS aktualisiert libc6 nicht auf 2.15-0ubuntu10.10

In Anbetracht von CVE-2015-0235 habe ich mich vorgenommen, meine Ubuntu-Server heute zu aktualisieren. Ich habe einen 12.04.5 LTS-Server, der es ablehnt, mein libc6 -Paket auf die Version zu aktualisieren, die die Sicherheitsanfälligkeit nicht enthält (2.15-0ubuntu10.10, laut this ). Wenn ich apt-get update && apt-get upgrade und apt-get dist-upgrade ausführe, wurde libc6 auf die Version 2.15-0ubuntu10.9 aktualisiert, nicht auf 2.15-0ubuntu10.10. Nach der Aktualisierung der Pakete habe ich den Server neu gestartet.

Dann habe ich das C-Programm ausgeführt, das in der Sicherheitsempfehlung zu finden ist, um festzustellen, ob der Server immer noch anfällig ist, da die Ausgabe "anfällig" ist.

Meine /etc/apt/sources.list -Dateien enthalten die Ubuntu-Repositorys für präzise Sicherheit:

deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

Warum kann ich libc6 nicht auf 2.15-0ubuntu10.10 aktualisieren?

BEARBEITEN: Ich habe gerade versucht, die mit @ geoffmcc verknüpfte .deb von zu installieren Laufen dpkg -i libc6_2.15-0ubuntu10_AMD64.deb als root, und hier ist die Fehlermeldung, die ich bekomme:

dpkg: warning: downgrading libc6 from 2.15-0ubuntu10.9 to 2.15-0ubuntu10.
(Reading database ... 102787 files and directories currently installed.)
Preparing to replace libc6 2.15-0ubuntu10.9 (using libc6_2.15-0ubuntu10_AMD64.deb) ...
Unpacking replacement libc6 ...
dpkg: dependency problems prevent configuration of libc6:
 libc6 depends on libc-bin (= 2.15-0ubuntu10); however:
  Version of libc-bin on system is 2.15-0ubuntu10.9.
dpkg: error processing libc6 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6

BEARBEITEN 2: Ich habe keine Ahnung warum, aber wenn ich heute morgen noch einmal apt-get update && apt-get upgrade starte, werden die Updates angezeigt, die ich brauchte. Ich kann jetzt den C Vulnerability Checker ausführen und bekomme "nicht verwundbar" zur Ausgabe. Am Ende habe ich apt-get install -f ausgeführt, um .debs zu ersetzen, die ich manuell installiert habe, und die richtigen Versionen wurden installiert.

2
Nathan Jones

Wenn Sie auf einem 64-Bit-System arbeiten, lesen Sie This Launchpad und Sie finden dort die benötigte .deb-Datei. Wenn x86 sicher ist, können wir das bei Bedarf auch finden.

Bearbeiten: auch eine Paketsuche zeigt, dass Trusty 2.19-0Ubuntu6.4 und Utopic 2.19-10Ubuntu2.1 hat

Edit2: Dieses Launchpad hat den benötigten libc-bin

1
geoffmcc