it-swarm.com.de

Python-dev kann unter Ubuntu 16.04 LTS nicht mit aptitude und apt-get installiert werden

Ich versuche, python-dev auf einem Ubuntu 16.04 LTS (64-Bit) -Gast zu installieren, der auf einem Windows-Host ausgeführt wird. Ich habe versucht, mit apt-get und dann mit aptitude zu installieren, aber es treten anscheinend Fehler auf.

~$Sudo aptitude install python-dev

gibt,

The following NEW packages will be installed:
  libexpat1-dev{ab} libpython-dev{a} libpython2.7-dev{ab} python-dev python2.7-dev{ab} 
0 packages upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 28.2 MB of archives. After unpacking 42.1 MB will be used.
The following packages have unmet dependencies:
 python2.7-dev : Depends: python2.7 (= 2.7.11-7ubuntu1) but 2.7.12-1~16.04 is installed.
                 Depends: libpython2.7 (= 2.7.11-7ubuntu1) but 2.7.12-1~16.04 is installed.
 libexpat1-dev : Depends: libexpat1 (= 2.1.0-7) but 2.1.0-7ubuntu0.16.04.2 is installed.
 libpython2.7-dev : Depends: libpython2.7-stdlib (= 2.7.11-7ubuntu1) but 2.7.12-1~16.04 is installed.
                    Depends: libpython2.7 (= 2.7.11-7ubuntu1) but 2.7.12-1~16.04 is installed.
open: 20; closed: 1293; defer: 6; conflict: 6                                                                  o
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libexpat1-dev [Not Installed]                      
2)     libpython-dev [Not Installed]                      
3)     libpython2.7-dev [Not Installed]                   
4)     python-dev [Not Installed]                         
5)     python2.7-dev [Not Installed]                      



Accept this solution? [Y/n/q/?] 

als Ausgabe. Wohingegen,

~$Sudo apt-get install python-dev

gibt,

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-dev : Depends: libpython-dev (= 2.7.11-1) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.11-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ich habe Sudo aptitude update und Sudo aptitude upgrade ausgeführt, aber das löst das Problem nicht.

Außerdem habe ich die in den folgenden Links angegebenen Schritte ausgeführt:

aber nichts scheint zu funktionieren.

Aus der Meldung von aptitude geht hervor, dass die auf meinem System installierten Abhängigkeiten eine höhere Version aufweisen als das, was für das Paket erforderlich ist (z. B. sagt eine Meldung Depends: libpython2.7 (= 2.7.11-7ubuntu1) but 2.7.12-1~16.04 is installed.).

Ich vermute, meine Optionen sind entweder

  • deinstalliere die vorhandenen Pakete (was ich lieber nicht möchte), oder
  • füge ein aktualisiertes PPA für Python-Zeug hinzu.

Meine aktuellen Repositories sind:

~$egrep -v '^#|^ *$' /etc/apt/sources.list /etc/apt/sources.list.d/*
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial universe
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse

Irgendwelche Ideen, wie ich Python-Dev installieren kann?

Danke im Voraus!

5
ARV

Eine meiner Neuinstallationen verfügt über diese Repositorys. Ihnen fehlen anscheinend einige update Repositorys.

Ich habe * Sterne an diejenigen gesetzt, die ich auf Ihrer Liste nicht sehe.

[email protected]:~$ egrep -v '^#|^ *$' /etc/apt/sources.list /etc/apt/sources.list.d/*
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted
* /etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial universe
* /etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe
/etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse
* /etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
* /etc/apt/sources.list:deb http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
* /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security main restricted
* /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security universe
* /etc/apt/sources.list:deb http://security.ubuntu.com/ubuntu xenial-security multiverse
grep: /etc/apt/sources.list.d/*: No such file or directory
[email protected]:~$ 

Fügen Sie mindestens die update -Repositorys hinzu ... und führen Sie dann Folgendes aus:

$ Sudo apt update
$ Sudo apt upgrade
7
L. D. James

Durch Eingabe von "n" in die Eignungsfrage wird eine andere Lösung angeboten - das Herabstufen einiger Pakete. Es hat bei mir funktioniert!

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Downgrade the following packages:                                  
1)     libexpat1 [2.1.0-4ubuntu1.3 (now) -> 2.1.0-4ubuntu1 (trusty)]    
2)     libpython2.7 [2.7.6-8ubuntu0.3 (now) -> 2.7.6-8 (trusty)]        
3)     libpython2.7-minimal [2.7.6-8ubuntu0.3 (now) -> 2.7.6-8 (trusty)]
4)     libpython2.7-stdlib [2.7.6-8ubuntu0.3 (now) -> 2.7.6-8 (trusty)] 
5)     python2.7 [2.7.6-8ubuntu0.3 (now) -> 2.7.6-8 (trusty)]           
6)     python2.7-minimal [2.7.6-8ubuntu0.3 (now) -> 2.7.6-8 (trusty)]   

Accept this solution? [Y/n/q/?] y
5
nasser