it-swarm.com.de

npm: Hängt ab von: node-gyp (> = 0.10.9), wird aber nicht installiert

Ich möchte npm installieren. Ich habe alles aktualisiert, kann das Problem jedoch nicht beheben.

Die Nachricht, die ich erhalte, lautet:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: node-gyp (>= 0.10.9) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Kannst du mir helfen?

24
MatiasEze

Ich konnte npm folgendermaßen installieren:

Sudo apt-get install nodejs-dev node-gyp libssl1.0-dev

und

Sudo apt-get install npm
63
griever