it-swarm.com.de

Nicht erfüllte Abhängigkeiten von Zoneminder

Ich versuche, zoneminder auf Ubuntu 16.04 Server zu installieren und ich bekomme diesen Fehler wegen nicht erfüllter Abhängigkeiten. Wie kann ich das korrigieren?

[email protected]:/home/joey# apt-get install zoneminder
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
zoneminder : Depends: libavcodec57 (>= 7:3.4.2) but it is not installable or
                   libavcodec-extra57 (>= 7:3.4.2) but it is not installable
          Depends: libavformat57 (>= 7:3.4.2) but it is not installable
          Depends: libavresample3 (>= 7:3.4.2) but it is not installable
          Depends: libavutil55 (>= 7:3.4.2) but it is not installable
          Depends: libmp4v2-2 but it is not installable
          Depends: libswscale4 (>= 7:3.4.2) but it is not installable
          Depends: libvlc5 (>= 1.1.1) but it is not installable
          Depends: libx264-152 but it is not installable
          Depends: libjs-mootools (>= 1.4.5~debian1) but it is not             
          installable
          Depends: ffmpeg but it is not installable or
                   libav-tools but it is not installable
          Depends: libdbd-mysql-Perl but it is not installable
          Depends: libphp-serialization-Perl but it is not installable
          Depends: libnet-sftp-foreign-Perl but it is not installable
          Depends: libdevice-serialport-Perl but it is not installable
          Depends: libimage-info-Perl but it is not installable
          Depends: libjson-any-Perl but it is not installable
          Depends: libsys-mmap-Perl but it is not installable
          Depends: liburi-encode-Perl but it is not installable
          Depends: libclass-std-fast-Perl but it is not installable
          Depends: libsoap-wsdl-Perl but it is not installable
          Depends: libio-socket-multicast-Perl but it is not installable
          Depends: libsys-cpu-Perl but it is not installable
          Depends: libsys-meminfo-Perl but it is not installable
          Depends: libdata-uuid-Perl but it is not installable
          Depends: libnumber-bytes-human-Perl but it is not installable
          Depends: libfile-Slurp-Perl but it is not installable
          Depends: php5-apcu but it is not installable or
                   php-apcu but it is not installable
          Depends: php-apc but it is not installable or
                   php-apcu-bc but it is not installable
          Recommends: zoneminder-doc (>= 1.31.45~20180731103016-bionic) but 
it is not going to be installed
          Recommends: ffmpeg but it is not installable
E: Unable to correct problems, you have held broken packages.
[email protected]:/home/joey# apt install libavcodec57
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libavcodec57 is not available, but is referred to by another     
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libavcodec57' has no installation candidate
[email protected]:/home/joey# cat /etc/apt/sources.list
deb http://archive.ubuntu.com/ubuntu bionic main
deb http://archive.ubuntu.com/ubuntu bionic-security main
deb http://archive.ubuntu.com/ubuntu bionic-updates main
[email protected]:/home/joey#
2
sealfab

OK, zuallererst hast du einen falschen sources.list, der nur den Hauptkanal enthält. Also mach Sudo gedit /etc/apt/sources.list und lass es so aussehen:

deb http://archive.ubuntu.com/ubuntu bionic main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu bionic-security main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu bionic-updates main multiverse restricted universe

Speichern und schließen. Dann aktualisieren Sie Ihr Repository:

Sudo apt update
3
Olimjon