it-swarm.com.de

Mongo kann wegen defekter Pakete nicht installiert werden

Wenn ich versuche, Mongo unter Ubuntu 14.04 zu installieren:

Sudo apt-get install -y mongodb-org

Ich erhalte den Fehler:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mongodb-org : Depends: mongodb-org-Shell but it is not going to be installed
               Depends: mongodb-org-server but it is not going to be installed
               Depends: mongodb-org-mongos but it is not going to be installed
               Depends: mongodb-org-tools but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Diese ähnliche Frage empfiehlt, apt-mark showhold auszuführen, um die zurückgehaltenen Pakete zu finden und sie zurückzuhalten, aber es wird angezeigt, dass nichts zurückgehalten wird.

Was verursacht diesen Fehler und wie behebe ich ihn?

Ich installiere Mongo von Mongos PPA. Und ich hatte zuvor PPAs für die Versionen 3.0 und 3.4 aktiviert. Ich habe die Datei /etc/apt/sources.list.d/mongodb-org-3.0.list für die Version 3.0 entfernt, um Konflikte zu vermeiden, aber ich denke, dass es immer noch einige Probleme geben kann.

5
Cerin

Ich hatte das gleiche Problem und das Problem war, dass libcurl3 nicht installiert war. das sollte funktionieren.

Sudo apt install libcurl3
4
Ahmed Shaltout

Es war nicht sofort offensichtlich, aber als ich zurück über die Dokumente ging, wurde mir klar, dass ich das PPA für die falsche Ubuntu-Version installiert habe. Das Entfernen und Installieren des richtigen hat den Fehler behoben.

3
Cerin