it-swarm.com.de

Libpcre3-dev kann nicht installiert werden

Ich versuche libpcre3-dev zu installieren, aber es gibt mir den folgenden Fehler:

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten: libpcre3-dev: Hängt ab von: libpcre3 (= 2: 8.38-3.1), aber 2: 8.39-1 + deb.sury.org ~ trusty + 1 muss installiert werden E: Probleme können nicht behoben werden, Sie haben kaputte Pakete gehalten.

Der 2:8.39-1+deb.sury.org~trusty+1 stammt von einem 'alten' ppa (ondrej), also habe ich ein neues Sources.list genommen.

Ich hatte das gleiche Problem mit php7.0-dev und deinstallierte schließlich php7.0 und installierte es von den offiziellen Repos.

Wenn ich jetzt libpcre3 entfernen möchte, möchte es fast alle meine Pakete entfernen? Gibt es eine andere Möglichkeit, das libpcre3-Paket in das "offizielle" zu "ändern"?

Ich habe auch versucht dies , ohne Glück

8
PrimuS

Verwenden

Sudo apt-get install libpcre3=2:8.38-3.1 libpcre3-dev=2:8.38-3.1

apt-get zwingen, Version 2: 8.38-3.1 dieser Pakete zu installieren.

Warnung: Verwenden Sie diese Option nur, wenn Sie wirklich sicher sind, dass Sie die Version 2: 8.38-3.1 (die Version von das offizielle buntu 16.04 Repository) der Pakete libpcre3 und libpcre3-dev.

Wenn Sie Ubuntu 16.04 nicht ausführen, sollten Sie die Versionsnummer in die Version ändern, die Sie tatsächlich installieren möchten.

11
Florian Diesch