it-swarm.com.de

Installieren Sie gcc unter Ubuntu 12.04 LTS

Wenn ich versuche, gcc unter Ubuntu 12.04 LTS Server mit apt-get install gcc zu installieren, wird die folgende Fehlermeldung angezeigt:

The following packages have unmet dependencies:
 gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) but it is not going to be installed
       Depends: gcc-4.6 (>= 4.6.1-1) but it is not going to be installed
       Recommends: libc6-dev but it is not going to be installed or
                   libc-dev

Wenn ich tiefer eintauche (d. H. Versuche, apt-get install gcc-4.6), erhalte ich:

 gcc-4.6 : Depends: gcc-4.6-base (= 4.6.1-9ubuntu3) but 4.6.3-1ubuntu5 is to be installed
           Depends: cpp-4.6 (= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libgomp1 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Depends: libquadmath0 (>= 4.6.1-9ubuntu3) but it is not going to be installed
           Recommends: libc6-dev (>= 2.13-0ubuntu6) but it is not going to be installed

Wenn ich also versuche, gcc-4.6=4.6.1-9ubuntu3 zu installieren, erhalte ich eine Liste von 366 zu entfernenden Paketen (einschließlich z. B. apt). Welches ist Verrücktheit.

Dies ist im Wesentlichen eine Vanilla-Installation von Ubuntu 12.04 LTS Server (d. H. Ich habe Nginx, Python-Flup, Python-Yaml, Rsync, Python-Pkg-Ressourcen, Isof, Fontconfig, Iptables, Ufw, Scons und Grc installiert).

Es ist sehr überraschend für mich, dass ich gcc nicht installieren kann, und ich bin etwas verwirrt darüber, warum der Versuch, gcc zu installieren, fehlschlägt. Die einzige offensichtliche Lösung scheint die Deinstallation von 366 Paketen zu sein, von denen viele für den Betrieb von Ubuntu von zentraler Bedeutung sind.

Etwas passt nicht zusammen und ich wäre sehr dankbar für Hilfe.

EDIT Das obige ist natürlich mit den neuesten Paketen, die apt-get update; apt-get upgrade verwendet haben, bevor sie das obige versucht haben. Entschuldigung, das hätte ich erwähnen sollen.

54
Brian M. Hunt

Es gibt ein Metapaket namens build-essential, das den Compiler und eine Reihe zugehöriger/benötigter Pakete installieren soll:

Sudo apt-get install build-essential

Der Vorschlag, zuerst Sudo apt-get update zu machen, ist gut. Dadurch werden die Paketlisten aktualisiert und alle Versionen sollten gut übereinstimmen.

Dies ist jedoch der Fall, wenn Sie Ihre /etc/apt/sources.list -Datei nicht manuell geändert haben. In diesem Fall enthalten möglicherweise einige der von Ihnen vorgenommenen Änderungen oder hinzugefügten Repositorys widersprüchliche Pakete, die die angezeigten Probleme verursachen. In diesem Fall schauen Sie sich bitte die Datei an und korrigieren Sie die fehlerhaften Einträge. Wenn Sie dabei Hilfe benötigen, können Sie natürlich Ihre sources.list -Datei (oder Fragmente in /etc/apt/sources.list.d) posten, und möglicherweise kann Ihnen jemand dabei helfen, diese zu beheben.

88
roadmr

Versuche weiter zu gehen:

Sudo apt-get update
Sudo apt-get install gcc-4.6-base cpp-4.6 libgomp1 libquadmath0 libc6-dev
4
David M. Sousa

Schreiben Sie zuerst den Befehl:

Sudo apt-get update.

Dann versuche es:

Sudo apt-get install gcc

Ich habe das getan und es hat funktioniert! Sie sollten es auch versuchen.

Wenn es nicht funktioniert, dann:

Sudo apt-get install build-essential

Dann versuchen Sie es. Ich hoffe, es wird funktionieren!

1