it-swarm.com.de

Ich kann Sudo apt-get install <anything> nicht ausführen

Auf meinem Terminal wird der folgende Fehler angezeigt

E: Das Paket libllvm3.8 muss neu installiert werden, aber ich kann kein Archiv dafür finden.

wenn ich versuche, apt-get install oder apt-get upgrade auszuführen. Bitte helfen Sie. Danke im Voraus.

1
Vishesh Dembla

lauf Sudo apt install -f dann renne Sudo dpkg --configure -a

Aus der Manpage: Konfigurieren Sie ein Paket, das entpackt, aber noch nicht konfiguriert wurde. Wenn anstelle von package -a oder --pending angegeben wird, werden alle entpackten, aber nicht konfigurierten Pakete konfiguriert.

von der Manpage: -f, --fix-broken Fix; Versuchen Sie, ein System mit fehlerhaften Abhängigkeiten zu korrigieren. Wenn diese Option mit install/remove verwendet wird, können alle Pakete weggelassen werden, um APT eine wahrscheinliche Lösung abzuleiten. Wenn Pakete angegeben werden, müssen diese das Problem vollständig beheben. Die Option ist manchmal erforderlich Wenn APT zum ersten Mal ausgeführt wird; APT selbst lässt nicht zu, dass fehlerhafte Paketabhängigkeiten auf einem System existieren. Möglicherweise kann die Abhängigkeitsstruktur eines Systems sein Die Verwendung dieser Option zusammen mit -m kann in bestimmten Situationen zu einem Fehler führen. Konfigurationselement: APT :: Get :: Fix-Broken.

2
answerSeeker