it-swarm.com.de

Fehlerhafte Pakete bei der Installation von Gazebo 8.0 unter Ubuntu

Ich versuche, Gazebo 8.0 Simulator für Ubuntu 16.04 zu installieren. Ich habe das .deb-Paket ausprobiert, das mir dieses Bash-Skript gab:

gazebo8_install.sh:

# Description:
# This script installs gazebo onto an Ubuntu system.

codename=`lsb_release -sc`

# Make sure we are running a valid Ubuntu distribution
case $codename in
  "xenial" | "yakkety" )
  ;;
  *)
    echo "This script will only work on Ubuntu xenial, and yakkety"
    exit 0
esac

# Add the OSRF repository
if [ ! -e /etc/apt/sources.list.d/gazebo-latest.list ]; then
  Sudo sh -c "echo \"deb http://packages.osrfoundation.org/gazebo/ubuntu ${codename} main\" > /etc/apt/sources.list.d/gazebo-latest.list"
fi

# Download the OSRF keys
has_key=`apt-key list | grep "OSRF deb-builder"`

echo "Downloading keys"
if [ -z "$has_key" ]; then
  wget --quiet http://packages.osrfoundation.org/gazebo.key -O - | Sudo apt-key add -
fi


# Update apt
echo "Retrieving packages"
Sudo apt-get update -qq
echo "OK"

# Install gazebo
echo "Installing Gazebo"
Sudo apt-get install gazebo8 libgazebo8-dev

echo "Complete."
echo "Type gazebo to start the simulator."

Ich habe es auf dem Terminal mit folgender Ausgabe ausgeführt:

Downloading keys
OK
Retrieving packages
OK
Installing Gazebo
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gazebo8 : Depends: libgazebo8 (= 8.0.0-1~xenial) but it is not going to be installed
           Depends: libsdformat5 but it is not going to be installed
           Recommends: gazebo8-plugin-base
 libgazebo8-dev : Depends: libsdformat5-dev but it is not going to be installed
                  Depends: libignition-math3-dev (> 3.0.0-1) but it is not going to be installed
                  Depends: libignition-transport3-dev (> 3.0.1-1) but it is not going to be installed
                  Depends: libignition-msgs-dev (>= 0.6.999) but it is not going to be installed
                  Depends: libgazebo8 (= 8.0.0-1~xenial) but it is not going to be installed
                  Depends: gazebo8-plugin-base (= 8.0.0-1~xenial)
E: Unable to correct problems, you have held broken packages.
Complete.
Type gazebo to start the simulator.

Es heißt, ich hätte kaputte Pakete in der Hand gehalten. Aber der Befehl apt-mark showhold gibt leer zurück. Ich habe versucht, Gazebo zu starten, aber es startet gazebo7.0 nicht 8.0. Was ist das Problem hier und wie löse ich es?

1
kneelb4darth

In meinem Setup hatte der libsdformat5-dev einen Konflikt, da auch eine frühere Version vorhanden war. Es gab auch einen Konflikt im libignition-math3 -Paket, der als Voraussetzung für libsdformat5-dev gedacht war. Nachdem die Konflikte in Abhängigkeiten gelöst wurden, wurde alles in Ordnung installiert.

1
kneelb4darth

Ich hatte die beschriebenen Schritte befolgt hier und am Ende die gleichen Fehlermeldungen erhalten, die darauf hinweisen, dass ungelöste Abhängigkeiten mit libsdformat5 bestehen.

Was das Problem löste, war zuerst die Installation von libignition-math3

Sudo apt-get install libignition-math3

Das Ausführen löste die Abhängigkeitskonflikte. Danach installiere ich gazebo8:

Sudo apt-get install gazebo8

Und es hat funktioniert, ich hoffe das hilft.

1
Jorge Nicho