it-swarm.com.de

Fehler beim Zugriff auf LLVM Debian / Ubuntu-Pakete für die Nacht

Der Versuch, auf LLVM-Debian/Ubuntu-Pakete für die Nacht zuzugreifen

Ich bin am 14.04 und sie geben diese Info:

Das Ziel ist es, Debian- und Ubuntu-Pakete für die Nacht bereitzustellen, die so installiert werden können, dass sie sich nur minimal auf die Distribution auswirken. Pakete sind für AMD64 und i386 sowie für die Bereiche Stable, Qualification und Development (derzeit 3.9, 4.0 und 5.0) verfügbar.

Die Pakete enthalten LLVM + Clang + Compiler-RT + Polly + LLDB + LLD + LibFuzzer

Trusty (14.04) - Last update : Wed, 22 Mar 2017 08:38:03 UTC / Revision: 298477

deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty main
deb-src http://apt.llvm.org/trusty/ llvm-toolchain-trusty main
# 3.9 
deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.9 main
deb-src http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.9 main
# 4.0 
deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-4.0 main
deb-src http://apt.llvm.org/trusty/ llvm-toolchain-trusty-4.0 main

Ich habe versucht, im Ubuntu Software Center die Deb-Zeile für 3.9 und 4.0 hinzuzufügen. Aber nach Sudo apt-get update bekomme ich einen Fehler:

W: GPG error: http://apt.llvm.org llvm-toolchain-trusty-3.9 InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 15CF4D18AF4F7421

Es gibt eine Möglichkeit, dies ohne Ubuntu Software Center zu installieren, aber ich weiß nicht, wie ich den ppa: user/ppa-Namen finde, über den hier gesprochen wurde

3
Scooter

Ich bekam den gleichen Fehler. Ich habe es behoben, indem ich launchpad-getkeys installiert habe:

Sudo add-apt-repository ppa:nilarimogard/webupd8
Sudo apt-get update
Sudo apt-get install launchpad-getkeys

Führen Sie nach der Installation Folgendes aus:

Sudo launchpad-getkeys
Sudo apt-get update

Ihre Schlüsselfehler sollten verschwunden sein.

4
Gnawme

Jedes dieser Repositorys verfügt über einen eigenen Schlüssel, den Sie hinzufügen sollten, bevor Sie Ihre Listen aktualisieren. Siehe https://apt.llvm.org/

Zum Beispiel, wenn Sie diesen zu Ihren Quellen hinzufügen:

deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty main

Dann sollten Sie auch den zugehörigen Schlüssel zu dieser Komponente hinzufügen:

wget -O - https://apt.llvm.org/llvm-snapshot.gpg.key|Sudo apt-key add -

Wenn Sie also alle Zeilen für "vertrauenswürdig" hinzufügen, sollten Sie alle drei zugehörigen Schlüssel hinzufügen. Dadurch wird Ihr Fehler behoben.


Für einen stabilen Brunch (V3), Quelle:

 deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-3.9 main

 wget -O - https://apt.llvm.org/llvm-snapshot.gpg.key|Sudo apt-key add -

Für Qualifizierungszweig (V4), Quelle:

deb http://apt.llvm.org/trusty/ llvm-toolchain-trusty-4.0 main

wget -O - https://apt.llvm.org/llvm-snapshot.gpg.key|Sudo apt-key add -
4
Ravexina