it-swarm.com.de

Fehler beim Installieren von Wein in Ubuntu 14.04 LTS

Ich habe die folgenden Anweisungen befolgt, um wine in Ubuntu 14.04 LTS zu installieren:

add-apt-repository ppa:ubuntu-wine/ppa 
apt-get update 
apt-get install -y wine

Es werden jedoch die folgenden Fehlermeldungen angezeigt:

The following packages have unmet dependencies:

 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed

 wine : Depends: wine1.6 but it is not going to be installed or
                 wine1.8 but it is not going to be installed

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Nachdem ich das System überprüft habe, wurde unity-control-center bereits installiert. Beim Versuch, wine1.6 zu installieren, wird dieselbe Fehlermeldung angezeigt.

Jede Hilfe wird geschätzt!

Vielen Dank!

============

aktualisiert

Nach den Vorschlägen von A.B. sind dies die Ergebnisse:

lsb_release -a

LSB Version:    core-2.0-AMD64:core-2.0-noarch:core-3.0-AMD64:core- 3.0-noarch:core-3.1-AMD64:core-3.1-noarch:core-3.2-AMD64:core-3.2-noarch:core-4.0-AMD64:core-4.0-noarch:core-4.1-AMD64:core-4.1-noarch:security-4.0-AMD64:security-4.0-noarch:security-4.1-AMD64:security-4.1-noarch
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.3 LTS
Release:    14.04
Codename:   trusty

uname -a

Linux yiliang-PORTEGE-Z930 3.19.0-43-generic #49~14.04.1-Ubuntu SMP Thu Dec 31 15:44:49 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

apt-get install libcheese-gtk23 libcheese7

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcheese-gtk23 is already the newest version.
libcheese7 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

apt-get install wine1.8

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 wine1.8 : Depends: wine1.8-i386 (= 1:1.8.0-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

Die Ausgabe von

apt-cache policy wine wine1.6 wine 1.8 unity-control-center libcheese-gtk23 libcheese7

ist sehr lang und kann von hier aufgerufen werden.

wine:
  Installed: (none)
  Candidate: 1:1.8.0-0ubuntu1
  Version table:
     1:1.8.0-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ trusty/main AMD64 Packages
     1:1.6.2-0ubuntu4 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty/universe AMD64 Packages

wine1.6:
  Installed: (none)
  Candidate: 1:1.6.2-0ubuntu4
  Version table:
     1:1.6.2-0ubuntu4 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty/universe AMD64 Packages

wine1.8:
  Installed: (none)
  Candidate: 1:1.8.0-0ubuntu1
  Version table:
     1:1.8.0-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ trusty/main AMD64 Packages

unity-control-center:
  Installed: 14.04.3+14.04.20150916-0ubuntu1
  Candidate: 14.04.3+14.04.20150916-0ubuntu1
  Version table:
 *** 14.04.3+14.04.20150916-0ubuntu1 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty-updates/main AMD64 Packages
        100 /var/lib/dpkg/status
     14.04.3+14.04.20140410-0ubuntu1 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty/main AMD64 Packages

libcheese-gtk23:
  Installed: 3.10.2-0ubuntu2
  Candidate: 3.10.2-0ubuntu2
  Version table:
 *** 3.10.2-0ubuntu2 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty/main AMD64 Packages
        100 /var/lib/dpkg/status

libcheese7:
  Installed: 3.10.2-0ubuntu2
  Candidate: 3.10.2-0ubuntu2
  Version table:
 *** 3.10.2-0ubuntu2 0
        500 http://sg.archive.ubuntu.com/ubuntu/ trusty/main AMD64 Packages
        100 /var/lib/dpkg/status

wine1.8-i386:
  Installed: (none)
  Candidate: (none)
  Version table:
2
Yiliang

Sie müssen die 32-Bit-Unterstützung in apt unter Ubuntu 14.04 64-Bit aktivieren, um wine erfolgreich zu installieren:

Sudo dpkg --add-architecture i386
Sudo apt-get update
Sudo apt-get install wine
1
ericdagenais