it-swarm.com.de

Der Versuch, Java 8 zu installieren. Das Paket openjdk-8-jre konnte nicht gefunden werden

Ich versuche, Java JRE 8 zu installieren. Ich habe versucht, den Anweisungen von apt-get zu folgen, aber es kann dort nicht gefunden werden. Ich habe versucht, es direkt von der Oracle-Website herunterzuladen, und ich habe den Ordner jetzt in meinem Ordner/downloads/javajre, aber ich habe immer noch JDK7 auf meinem Computer und weiß nicht, wie ich es überschreiben soll. Ich habe die Pfadvariable zu meinem Ordner ~./Bashrc hinzugefügt, aber JDK7 wird weiterhin als Hauptversion von Java erkannt. Ich habe auch versucht, JDK7 zu entfernen und es wurde deinstalliert, aber es wird immer noch für Java --version angezeigt. Ich habe auch versucht, die Umgebungsvariable für JDK7 zu finden, und ich kann sie nicht finden, sie befindet sich nicht in/etc/environment. Also versuche ich, die apt-get zum Laufen zu bringen, damit ich die Version einfach über change-configuration ändern kann, aber sie kann nicht gefunden werden.

Ich habe es auch versucht, aber es hat nicht funktioniert:

Sudo add-apt-repository ppa:webupd8team/Java
$ Sudo apt-get update
$ Sudo apt-get install Oracle-Java8-installer 

Ich muss das zum Laufen bringen. Das erste ist meine Version, das zweite ist der Befehl und die Ausgabe.

  lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 14.04.4 LTS
    Release:    14.04
    Codename:   trusty

Sudo apt-get install openjdk-8-jre
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package openjdk-8-jre

Irgendwelche Ideen? Ich habe jetzt 4 Stunden lang versucht, das herauszufinden.

5
king

OpenJDK8 ist nicht in Ubuntu 14.04-Repositories enthalten.

Sie können Openjdk8 von einem PPA auf Ubuntu 14.04 folgendermaßen installieren:

Sudo add-apt-repository ppa:openjdk-r/ppa
Sudo apt-get update
Sudo apt-get install openjdk-8-jre
11
Pilot6