it-swarm.com.de

Defektes Apt, libglvnd kann aufgrund nicht erfüllter Abhängigkeiten nicht aktualisiert werden (Nvidia)

Ich habe in letzter Zeit keine neuen Pakete installiert oder PPAs hinzugefügt, sondern nur apt update ausgeführt.

Nach dem Ausführen von 'apt upgrade'

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libglvnd-dev : Depends: libglvnd0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libglvnd-core-dev (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libegl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libgles2 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libgl1 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libglx0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
                Depends: libopengl0 (= 1.0.0-2ubuntu2.1) but 1.0.0-2ubuntu2.2 is installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Nach dem Ausführen von 'apt --fix-broken install' oder 'apt-get install -f'

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libgles1 libglvnd-dev
The following NEW packages will be installed:
  libgles1
The following packages will be upgraded:
  libglvnd-dev
1 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/14.6 kB of archives.
After this operation, 66.6 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 686678 files and directories currently installed.)
Preparing to unpack .../libgles1_1.0.0-2ubuntu2.2_AMD64.deb ...
Unpacking libgles1:AMD64 (1.0.0-2ubuntu2.2) ...
dpkg: error processing archive /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_AMD64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1', which is also in package nvidia-340 340.106-0ubuntu3
Preparing to unpack .../libglvnd-dev_1.0.0-2ubuntu2.2_AMD64.deb ...
Unpacking libglvnd-dev:AMD64 (1.0.0-2ubuntu2.2) over (1.0.0-2ubuntu2.1) ...
dpkg: error processing archive /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_AMD64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libGLESv1_CM.so', which is also in package nvidia-340 340.106-0ubuntu3
Errors were encountered while processing:
 /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_AMD64.deb
 /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_AMD64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Ich habe versucht, vorübergehend wieder zu Nouoveau zu wechseln, aber aufgrund von Unordnung kann ich das nicht. Die Steuerdatei fordert alle Abhängigkeiten auf, * -2.2 zu sein, aber wenn ich versuche, ein Upgrade durchzuführen, fragt sie nach * -2.1.

UPDATE Ich habe es durch Ausführen behoben

Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_AMD64.deb
Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_AMD64.deb
Sudo apt -f install
10
pibacco

@ Pibacco Lösung auf Frage hat bei mir funktioniert:

UPDATE Ich habe es durch Ausführen behoben

Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libglvnd-dev_1.0.0-2ubuntu2.2_AMD64.deb 
Sudo dpkg -i --force-overwrite /var/cache/apt/archives/libgles1_1.0.0-2ubuntu2.2_AMD64.deb 
Sudo apt -f install
Sudo apt update
Sudo apt upgrade
7
Andres

Sie müssen Pakete vollständig von entfernen

Sudo dpkg --purge --force-depends "libgles1" 
Sudo dpkg --purge --force-depends "libglvnd-dev"
Sudo apt-get autoremove
Sudo apt-get clean
Sudo apt-get install -f

Sie können auch nbefriedigte Abhängigkeiten können nicht gelöst werden und Die Installation von Sudo apt-get -f schlägt fehl

2
nilesh_101