it-swarm.com.de

Cuda hat unerfüllte Abhängigkeiten. Kann nicht installiert werden

Ich habe versucht, cuda zu installieren, und ich kann es nicht für mein ganzes Leben herausfinden :(. Dies ist der Fehler, auf den ich laufe, und ich kann mir keine Pakete vorstellen, die auf diesem Computer kaputt gehen würden. Es ist eine Neuinstallation von Ubuntu Server (uname -a Linux marte 4.18.0-11-generic #12-Ubuntu SMP Tue Oct 23 19:22:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux mit Cosmic)

% Sudo apt-get install cuda
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-10-0 (>= 10.0.130) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Einige andere möglicherweise nützliche Informationen?

Mein Versuch, defekte Pakete zu finden

% Sudo debsums --changed
Sudo debsums --changed  7.72s user 3.54s system 22% cpu 49.658 total

/etc/apt/sources.list

deb http://archive.ubuntu.com/ubuntu cosmic main universe
deb http://archive.ubuntu.com/ubuntu cosmic-security main universe
deb http://archive.ubuntu.com/ubuntu cosmic-updates main universe

Bearbeiten: Gehen Sie den ganzen Hasen runter, um zu versuchen, nicht erfüllte Abhängigkeiten manuell zu installieren, ich bin an die folgende Wand gekommen

The following packages have unmet dependencies:
 nvidia-410 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23 but it is not installable
              Recommends: nvidia-settings (>= 331.20) but it is not going to be installed
              Recommends: nvidia-prime (>= 0.5) but it is not going to be installed or
                          bumblebee but it is not going to be installed

Hat jemand irgendwelche Vorschläge?

1
j-money

Das Paket, das xorg-vide-abi- * bereitstellt, war xserver-xorg-core (2: 1.19.6-ubuntu4.2), aber das zurückgehaltene Paket war xserver-xorg-core (2: 1.20 *) und lieferte den xerver nicht mehr -xorg-Core-Paket erforderlich

Das Herunterstufen des Pakets hat also funktioniert, und das Ignorieren des Pakets (Sudo apt-mark hold xserver-xorg-core) beim Upgrade hat den Trick getan

2
j-money

das Problem ist, dass Ubuntu nicht weiß, wo diese Pakete zu finden sind. Geben Sie den folgenden Code in das Terminal ein:

add-apt-repository ppa:graphics-drivers/ppa
2
jiang xu