it-swarm.com.de

Chrome -Updates schlagen fehl, wenn Repository-Informationen aktualisiert werden

Beim Ausführen von Sudo apt-get update erhalte ich den Fehler:

Fehler beim Abrufen von http://dl.google.com/linux/chrome/deb/dists/stable/Release Der erwartete Eintrag "main/binary-i386/Packages" in der Release-Datei konnte nicht gefunden werden (Falsch sources.list-Eintrag oder fehlerhafte Datei)

Das hat aber bis vor ein paar Tagen funktioniert. Die erwähnte Webadresse dl.google.com/.../stable/Release existiert tatsächlich, enthält aber nur Architectures: AMD64. In der Fehlermeldung wird binary-i386 erwähnt, bei dem es sich nicht um AMD64 handelt.

Ich habe alle üblichen Korrekturen für allgemeine "Fehler beim Abrufen" -Probleme versucht, aber in diesem Fall machte es keinen Unterschied. Irgendwelche Vorschläge? Wie kann ich die Fehlermeldung beheben?

Dies liegt daran, dass Google die Unterstützung für die 32-Bit-Version von chrome oder Chrom eingestellt hat.

Bitte bearbeiten Sie /etc/apt/sources.list.d/google-chrome.list, ersetzen Sie die Zeile

deb http://dl.google.com/linux/chrome/deb/ stable main

Durch

deb [Arch=AMD64] http://dl.google.com/linux/chrome/deb/ stable main

Sie sollten auch die Liste anderer Quellen unter /etc/apt überprüfen, insbesondere /etc/apt/sources.list, und alle Zeilen einschließlich http://dl.google.com/linux/chrome/deb/ entfernen. Mit dem folgenden Befehl können Sie solche Dateien leichter finden.

grep "http://dl.google.com/linux/chrome/deb/" -r /etc/apt
11
Tianren Liu

Versuchen Sie die Anweisungen hier:

https://www.reddit.com/r/chrome/comments/48oje6/linux_how_to_fix_failed_to_fetch/

Hat für mich gearbeitet

0
Sennic