it-swarm.com.de

Bücherwurm-Installation schlägt mit dem Fehler "Nicht erfüllte Abhängigkeiten" fehl

$ apt install bookworm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 bookworm : Depends: libgranite3 (>= 0.2.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

$ apt policy bookworm libgranite3
bookworm:
  Installed: (none)
  Candidate: 0.6-0~42~ubuntu16.04.1
  Version table:
     0.6-0~42~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/bookworm-team/bookworm/ubuntu xenial/main AMD64 Packages
libgranite3:
  Installed: (none)
  Candidate: (none)
  Version table:

$ lsb_release -sd
Ubuntu 16.04.3 LTS
2

Ich habe den Entwickler hinter ppa: bookworm-team/bookworm kontaktiert, aber anscheinend pflegt er den Bücherwurm nicht mehr . Stattdessen verwies er mich auf ppa: bablu-boy/bookworm-daily , wo die Software in einem gepflegten Zustand verfügbar ist.

Gehen Sie folgendermaßen vor, um das alte Programm (Spuren davon) zu deinstallieren und das fehlerhafte PPA zu entfernen:

  • deinstalliere das Programm

    Sudo apt remove bookworm
    
  • entfernen Sie den alten PPA

    Sudo add-apt-repository -r ppa:bookworm-team/bookworm
    

Gehen Sie wie folgt vor, um die neue PPA hinzuzufügen und das Programm zu installieren:

  • fügen Sie die neue PPA hinzu

    Sudo add-apt-repository ppa:bablu-boy/bookworm-daily
    
  • aktualisieren Sie die Paketquellen

    Sudo apt update
    
  • install bookworm

    Sudo apt install bookworm
    
5
dessert

Das hat bei mir nicht funktioniert. Es ist mit einer nicht erfüllten Abhängigkeit von libgranite4 fehlgeschlagen.
Ich konnte Bookworm installieren, indem ich den repo ppa:elementary-os/stable hinzufügte, den ich in diesem Beitrag gefunden habe.

4
Jim G.

(Dies ist auf Ubuntu 16.04 getestet)
Wie Jim G. sagte, müssen Sie das Elementary OS Team PPA zur Apt Repo-Liste hinzufügen. Ich weiß nicht warum, vielleicht ist diese App für elementare Betriebssysteme, aber das funktioniert:

Sudo add-apt-repository ppa:elementary-os/stable
Sudo apt-get update
Sudo apt-get install bookworm

Die zweite Möglichkeit besteht darin, aptitude und dann aptitude install zu installieren. Eignung scheint mit diesen Situationen umzugehen:

Sudo apt-get install aptitude
Sudo aptitude install bookworm
0
AmirHossein