it-swarm.com.de

Aktualisiert auf 18.04 und hat jetzt viele fehlerhafte Pakete und nicht erfüllte Abhängigkeiten

Ich habe einen furchtbaren Fehler gemacht und ein Upgrade auf 18.04 durchgeführt, ohne eine Sicherungskopie auf einer anderen Partition zu erstellen:

Sudo apt update
Sudo apt upgrade
Sudo apt dist-upgrade
Sudo apt-get autoremove
Sudo apt install update-manager-core
Sudo do-release-upgrade -d

Dann habe ich Befehle nach einem Neustart aktualisiert und aktualisiert. Es gibt jetzt viele Probleme mit nicht erfüllten Abhängigkeiten und fehlerhaften Paketen, die mit den Befehlen Sudo apt-get -f install nicht behoben werden können. UPDATE Der erste Teil der Ausgabe des Sudo apt install -f-Fehlerprotokolls lautet:

    Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... failed.
The following packages have unmet dependencies:
 gnome-calendar : Depends: gsettings-desktop-schemas (>= 3.21.2) but 3.18.1-1ubuntu1 is installed
 gnome-session : Depends: gnome-Shell (>= 3.25.91-0ubuntu4~) but it is not installed
                 Depends: gnome-session-bin (>= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed
                 Depends: gnome-session-common (= 3.28.1-0ubuntu2) but 3.18.1.2-1ubuntu1.16.04.2 is installed
                 Depends: xwayland but it is not installed
                 Recommends: fonts-cantarell but it is not installed
                 Recommends: adwaita-icon-theme-full
                 Recommends: gnome-themes-extra but it is not installed
 gnome-settings-daemon : Depends: libgnome-desktop-3-17 (>= 3.17.92) but it is not installed
                         Depends: gsettings-desktop-schemas (>= 3.20) but 3.18.1-1ubuntu1 is installed
 hplip : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 libc-dev-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1 is installed
 libc6-dbg : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libc6-dev : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libgmime-3.0-0 : Depends: libgpgme11 (>= 1.7.0) but 1.6.0-1 is installed
 libreoffice-avmedia-backend-gstreamer : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed
 libreoffice-base-core : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed
 libreoffice-calc : Depends: libreoffice-base-core (= 1:6.0.3-0ubuntu1) but 1:5.1.6~rc2-0ubuntu1~xenial3 is installed
                    Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed
 libreoffice-core : Depends: libgpgmepp6 (>= 1.10.0) but it is not installed
                    Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed
                    Depends: libpoppler73 (>= 0.62.0) but it is not installed
                    Depends: libxmlsec1 (>= 1.2.25) but it is not installed
                    Depends: libxmlsec1-nss (>= 1.2.25) but it is not installed
 libreoffice-gnome : Depends: libreoffice-gtk3 but it is not installed
 libreoffice-gtk : Depends: libreoffice-gtk2 but it is not installed
 libreoffice-math : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial3) but 1:6.0.3-0ubuntu1 is installed
 libreoffice-writer : Depends: libreoffice-base-core (= 1:6.0.3-0ubuntu1) but 1:5.1.6~rc2-0ubuntu1~xenial3 is installed
                      Depends: libabw-0.1-1 but it is not installed
                      Depends: libepubgen-0.1-1 (>= 0.1.0) but it is not installed
 libtotem0 : Depends: libgnome-desktop-3-17 (>= 3.17.92) but it is not installed
 libwayland-egl1-mesa : Depends: libegl1 but it is not installed
 libwebkitgtk-1.0-0 : Depends: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) but 2.4.11-3ubuntu3 is installed
                      Depends: libwebkitgtk-1.0-common (>= 2.4.11) but it is not installable
 nautilus : Depends: libgnome-desktop-3-17 (>= 3.18.1) but it is not installed
 python3-brlapi : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-cffi-backend : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-crypto : Depends: python3 (< 3.6) but 3.6.5-3 is installed

und

E: Error, pkgProblemResolver::Resolve generated breaks,   
this may be caused by held packages.  

Der Versuch, beschädigte Pakete in Synaptic zu reparieren, führt zu folgender Fehlermeldung:

E: Error, pkgProblemResolver::Resolve generated breaks,   
this may be caused by held packages.     

Es sieht nicht so aus, als ob irgendetwas mit der Datei sources.list nicht stimmt, und es scheint aktualisiert worden zu sein, als ich die Installation versuchte. Ich weiß kaum, was ich tue, und gebe gerne nähere Informationen zu Fehlermeldungen. Wenn es eine Möglichkeit gibt, das Scrollen in xterm zu aktivieren, verwende ich diese jetzt, da das Gnome-Terminal nicht geöffnet werden kann.

Ich möchte alle 47 defekten und zurückgehaltenen Pakete entfernen, sie korrekt neu installieren oder sie vorerst nicht installieren, wenn dies eine Option ist (z. B. für Dinge wie LibreOffice, die derzeit nicht erforderlich sind), und in der Lage sein, die zu verwenden Gnome-Terminal.

Ich bin auf der Suche nach Einsteigerschritten, um all diese Probleme zu beheben. Gibt es eine Anleitung, wie man anfängt? Ein offensichtlicher Beitrag, den ich bei der Suche nach Antworten verpasst habe? Ich denke dieser Beitrag geht in die richtige Richtung, aber es ist ein wenig über meinem Kopf. Jede Hilfe wird sehr geschätzt. Ich frage mich, ob es wirklich einfacher wäre, mit einer neuen 16.04-Installation zu beginnen.

10
k.mat27

Ich hatte genau das gleiche Problem. Ich musste /var/lib/dpkg/status editieren und die gesamte Depends: -Zeile aus den Paketen entfernen, die sich beschwerten.
Ich bin mir nicht sicher, welche anderen Probleme dies verursachen könnte, aber es war das einzige, was dazu führte, dass apt-get install -f wieder funktionierte.

7
dmattp

Hier sind ein paar Dinge, die Sie ausprobieren sollten.

Methode Eins:

Dies ist am einfachsten zu versuchen. Anstatt Sudo apt-get install PACKAGENAME zu verwenden, wobei PACKAGENAME das Paket ist, das Sie mit dem apt-System installieren möchten, verwenden Sie Sudo apt-get install -f. Mit dem Parameter -f wird versucht, ein System zu korrigieren, bei dem Abhängigkeiten unterbrochen wurden. Anschließend können Sie das betreffende Paket installieren.

Öffne ein Terminal und tippe ein:

Sudo apt-get install -f

und drücken Sie ENTER.

Jetzt tippe ein:

Sudo dpkg --configure -a

und drücken Sie ENTER.

Nun noch einmal:

Sudo apt-get install -f

Methode zwei:

Aptitude ist eine Alternative zu apt-get, die Sie als übergeordneter Paketmanager verwenden können. Sie können es verwenden, um zu versuchen, Ihr Paket damit zu installieren, anstatt apt-get, aber zuerst müssen Sie aptitude installieren.

Öffne ein Terminal und tippe ein:

Sudo apt-get install aptitude

und drücken Sie ENTER.

Jetzt tippe ein:

Sudo aptitude install PACKAGENAME

und drücken Sie ENTER.

PACKAGENAME ist das Paket, das Sie installieren. Dadurch wird versucht, das Paket über aptitude anstelle von apt-get zu installieren, wodurch möglicherweise das Problem mit nicht erfüllten Abhängigkeiten behoben werden sollte.

WENN DIESE NICHT ARBEITEN

Das kaputte Paket ist wahrscheinlich gesperrt und muss gelöscht werden. Um die gesperrte Datei zu löschen, öffnen Sie ein Terminal und geben Sie Folgendes ein:

Sudo rm /var/lib/apt/lists/lock

und drücken Sie ENTER.

Die gesperrte Datei muss möglicherweise auch im Cache-Verzeichnis gelöscht werden. Öffnen Sie dazu ein Terminal und geben Sie Folgendes ein:

Sudo rm /var/cache/apt/archives/lock

Ich habe ein Upgrade von 16.04 durchgeführt und hatte viele verschiedene Probleme. Ich fand es viel einfacher, eine Neuinstallation durchzuführen. Eine frische oder saubere Installation ist meiner Meinung nach immer der richtige Weg.

Hoffe das hilft,

9
Dave

Ich möchte zu dieser Diskussion hinzufügen, indem ich sage, wenn ich das Upgrade auf 18.04 mit dem Software Updater durchführe und auf ein Problem stoße, dass die Lösung darin besteht, das Terminal zu öffnen und Folgendes einzugeben:

Sudo apt-get autoremove

gefolgt von dem, was anfangs dazu geführt hat, dass hier etwas schiefgelaufen ist, was zu dieser Diskussion geführt hat, die wie folgt lautet:

Sudo apt update
Sudo apt upgrade
Sudo apt dist-upgrade
Sudo apt-get autoremove
Sudo apt install update-manager-core
Sudo do-release-upgrade -d
1
JWeb777

"Wenn es eine Möglichkeit gibt, das Scrollen in xterm zu aktivieren" , da Sie nicht nach oben scrollen können kann die gesamte Ausgabe an eine Datei senden, indem Folgendes verwendet wird:

Sudo apt install -f > output.log

Bearbeiten Sie dann output.log und kopieren Sie die Nachrichten in Ihre Frage. Ihre Chancen auf eine gute Antwort verbessern sich mit mehr Informationen.


Soweit andere Benutzer ihre Daten vor dem Upgrade auf 18.04 auf eine Backup-Partition kopieren möchten, wird der folgende Befehl verwendet: Bash-Skript zum Klonen von Ubuntu auf eine neue Partition zum Testen des 18.04 LTS-Upgrades

rsync -haxAX --stats --delete --info=progress2 --info=name0 /* "$TargetMnt" \
      --exclude={/dev/*,/proc/*,/sys/*,/tmp/*,/run/*,/mnt/*,/media/*,/lost+found}

Bevor Sie den Befehl ausführen, müssen Sie eine Sicherungspartition erstellen und diese bereitstellen. Nach der Montage setzen Sie:

TargetMnt=/mnt/my_backup_partition_name

Eine einfachere Methode ist natürlich, das oben verlinkte Skript auszuführen. Es ermöglicht nicht nur die interaktive Auswahl der Backup-Partition, sondern auch die Validierung und Änderung von grub, sodass Sie die Backup-Partition bei Bedarf starten können.

PS: Ich bin traurig über deine Probleme und die vielen anderen Probleme, die ich hier in Ask Ubuntu seit dem Release vom 18.04 gelesen habe. Leider treten bei jeder neuen Version ähnliche Probleme auf. Hoffentlich betont Conical eines Tages, wie wichtig es ist, vor dem Upgrade zuerst ein Backup und/oder einen Test auf einer Klonpartition durchzuführen. Vor allem vor dem ersten Point Release vom 18.04.1, das am 26. Juli 2018 erscheint.

1

In der Tat hatte ich zu viele Probleme beim Upgrade von Xubuntu 16.04 auf 18.04. Ich musste gstreamer komplett aus dem System entfernen (nicht mit pulseaudio arbeiten, was sich merkwürdig verhält), abgesehen von vielen anderen Problemen, die nicht mit diesem Beitrag zusammenhängen (nvidia, netplan, baloo). In vielen Jahren der Verwaltung von Desktops und Servern war es meine schwerste Migration. Aus diesem Grund rate ich nicht zu einem UGrading auf 18.04 bevor es eine stabile Distribution ist.

Nach dem Upgrade hatte ich ein Problem mit den fehlenden pyhon3.7-Bibliotheken, ganze apt/dpkg wurden blockiert. Fehlender /usr/lib/python3.7/py_compile.py eine Ebene tiefer /usr/local/lib/python3.7 gefunden. Die Lösung, die für mich funktionierte, war das Sichern (Umbenennen) des gesamten /usr/lib/python3.7 und das Ersetzen durch sym-link.

Hier ist das Problem (apt install -f). Entschuldigung für die tschechische Sprache, wichtige Sachen sind auf Englisch

Načítají se seznamy balíků…
Vytváří se strom závislostí…
Načítají se stavové informace…
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 7 neaktualizováno.
39 instalováno nebo odstraněno pouze částečně.
Po této operaci bude na disku použito dalších 0 B.
Nastavuje se balík python3-tk:AMD64 (3.6.5-3) …
(null): can't open file '/usr/lib/python3.7/py_compile.py': [Errno 2] No such file or directory
dpkg: chyba při zpracovávání balíku python3-tk:AMD64 (--configure):
 installed python3-tk:AMD64 package post-installation script subprocess returned error exit status 2
Nastavuje se balík python3-lib2to3 (3.6.5-3) …
(null): can't open file '/usr/lib/python3.7/py_compile.py': [Errno 2] No such file or directory
dpkg: chyba při zpracovávání balíku python3-lib2to3 (--configure):
 installed python3-lib2to3 package post-installation script subprocess returned error exit status 2
dpkg: nesplněné závislosti zamezily konfiguraci balíku python3-distutils:
 python3-distutils závisí na python3-lib2to3 (>= 3.6.4); avšak:
  Balík python3-lib2to3 zatím není zkonfigurován.

...

dpkg: chyba při zpracovávání balíku libsdl-net1.2-dev:AMD64 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku libsdl-image1.2-dev:AMD64:
 libsdl-image1.2-dev:AMD64 závisí na libsdl1.2-dev (>= 1.2.14~); avšak:
  Balík libsdl1.2-dev zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku libsdl-image1.2-dev:AMD64 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku libboost-iostreams1.65-dev:AMD64:
 libboost-iostreams1.65-dev:AMD64 závisí na libboost-regex1.65-dev (= 1.65.1+dfsg-0ubuntu5); avšak:
  Balík libboost-regex1.65-dev:AMD64 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku libboost-iostreams1.65-dev:AMD64 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku libboost-iostreams-dev:AMD64:
 libboost-iostreams-dev:AMD64 závisí na libboost-iostreams1.65-dev; avšak:
  Balík libboost-iostreams1.65-dev:AMD64 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku libboost-iostreams-dev:AMD64 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
dpkg: nesplněné závislosti zamezily konfiguraci balíku libboost-regex-dev:AMD64:
 libboost-regex-dev:AMD64 závisí na libboost-regex1.65-dev; avšak:
  Balík libboost-regex1.65-dev:AMD64 zatím není zkonfigurován.

dpkg: chyba při zpracovávání balíku libboost-regex-dev:AMD64 (--configure):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 python3-tk:AMD64
 python3-lib2to3
 python3-distutils
 libglib2.0-dev-bin
 python3-dev
 libglib2.0-dev:AMD64
 libgdk-pixbuf2.0-dev
 libibus-1.0-dev:AMD64
 libboost-python1.65-dev
 libpango1.0-dev
 libsdl2-dev:AMD64
 libharfbuzz-dev:AMD64
 dh-python
 libsdl2-ttf-dev:AMD64
 libboost-python-dev
 libsdl2-image-dev:AMD64
 libpulse-dev:AMD64
 libicu-le-hb-dev:AMD64
 libcairo2-dev:AMD64
 libnotify-dev:AMD64
 libatk1.0-dev:AMD64
 libgtk2.0-dev
 librsvg2-dev:AMD64
 libicu-dev
 libass-dev:AMD64
 libxml2-dev:AMD64
 libsdl2-mixer-dev:AMD64
 libsdl1.2-dev
 libsdl-ttf2.0-dev:AMD64
 libboost-all-dev
 libboost-regex1.65-dev:AMD64
 libbluray-dev:AMD64
 libsdl-gfx1.2-dev:AMD64
 libsdl-mixer1.2-dev:AMD64
 libsdl-net1.2-dev:AMD64
 libsdl-image1.2-dev:AMD64
 libboost-iostreams1.65-dev:AMD64
 libboost-iostreams-dev:AMD64
 libboost-regex-dev:AMD64
0
czechDude

wenn Sie ein System haben, bei dem Sie sich nicht anmelden können, gehen Sie zu tty1 login mit der Tastenkombination Strg + Alt + F1 und versuchen Sie diesen Sudo apt-get install -f dist-upgrade, wenn Sie dort nach einer bestimmten Lösung zum Anwenden von Y/n gefragt werden. Verwenden Sie eine andere Option, indem Sie eingeben "." Für eine andere Lösung werden Sie mit einer anderen Lösung aufgeführt, um Ihr System vollständig zu aktualisieren. Wenn ein Problem auftritt, lassen Sie es mich wissen

0
Nikhil Lalwani

Was hat mir geholfen:

  1. verwenden von Sudo dpkg --remove [Paketname] zum Entfernen problematischer Pakete, die über Sudo dpkg --configure -a gefunden wurden (Quelle: https://stackoverflow.com/a/35969176/55722 ). Einige Pakete konnten nicht entfernt werden, da sie Abhängigkeiten von anderen Paketen waren.
  2. sudo apt-get install -f ausführen (es hat wieder funktioniert, yay)
  3. umbenennen der Datei org.freedesktop.systemd1.service wie in https://askubuntu.com/a/83867
  4. So führen Sie Sudo aus: apt-get update und dist-upgrade und autoremove sowie do-release-upgrade

Ein großes Lob an https://ubuntuforums.org/showthread.php?t=2398895&page=2 dragans2's Beitrag!

0
mmalmeida