it-swarm.com.de

Aktualisieren Sie das Python 3.6-Paket von Deadsnakes PPA

Ich kann meine Version von Python 3.6, die von deadsnakes ppa installiert wurde, scheinbar nicht aktualisieren.

Sudo apt-get update trifft den ppa und Sudo apt-get upgrade meldet keine Fehler.

Wenn ich apt policy python3.6 starte, erhalte ich:

python3.6:
  Installed: 3.6.2-1+xenial1
  Candidate: 3.6.2-1+xenial1
  Version table:
 *** 3.6.2-1+xenial1 500
        500 http://ppa.launchpad.net/fkrull/deadsnakes/ubuntu xenial/main AMD64 Packages
        100 /var/lib/dpkg/status

Die Webseite für das ppa sagt, dass die neueste Version von 3.6 3.6.5-1+xenial1 ist.

4
Morgoth

Sie verwenden das falsche PPA. Die ppa wurde von geändert

ppa:fkrull/deadsnakes bis ppa:deadsnakes/ppa

Wir können dies deutlich sehen, wenn wir uns die technischen Details des ppa ansehen: apt sollte sich ansehen

http://ppa.launchpad.net/deadsnakes/ppa/ubuntu ...

für verfügbare Pakete, nicht bei

http://ppa.launchpad.net/fkrull/deadsnakes/ubuntu
6
mook765