it-swarm.com.de

WAMP wird nicht grün. Und der VCRUNTIME140.dll-Fehler

WAMP wird nicht grün. Vor ein paar Wochen hat es gut funktioniert. Bei der Beantwortung anderer Antworten zu diesem Thema wurde häufig die Installation von Diensten in Apache angegeben.

Wenn ich dies tue, erhalte ich einen Fehlercode mit folgendem Hinweis:

"Das Programm kann nicht starten, da VCRUNTIME140.dll auf Ihrem Computer fehlt. Versuchen Sie, das Programm erneut zu installieren, um das Problem zu beheben."

86
Dylan Caudill

Wie Oriol sagte, benötigen Sie die folgenden Weiterverteiler, bevor Sie WAMP installieren.

Aus der readme.txt

Bevor Sie mit der Installation von Wampserver fortfahren, müssen Sie sicherstellen, dass dass bestimmte Elemente auf Ihrem System installiert sind, andernfalls Wampserver läuft absolut nicht und außerdem die Installation wird fehlerhaft sein und Sie müssen Wampserver entfernen, BEVOR Sie das .__ installieren. Elemente, die fehlten.

Stellen Sie sicher, dass Sie in den weitervertreibbaren Paketen VC9, .__, auf dem neuesten Stand sind. VC10, VC11, VC13 und VC14 Auch wenn Sie glauben, dass Sie auf dem neuesten Stand sind, Installieren Sie jedes Paket als Administrator. Wenn die Meldung "Bereits installiert" angezeigt wird, überprüfen Sie Repair. 

Die folgenden Pakete (VC9, VC10, VC11) sind für Wampserver 2.4, 2.5 und 3.0 zwingend erforderlich, auch wenn Sie nur Apache verwenden und PHP die Versionen VC11 und VC14 für PHP 7 und Apache 2.4 erforderlich sind. 17 

https://support.Microsoft.com/de-de/help/2977003/the-latest-supported-visual-c-downloads

144
sotoz

Recht einfach:

  1. Deinstallieren Sie den Wampserver
  2. Installieren Sie Visual C++ Redistributable für Visual Studio 2015
  3. Wampserver installieren
40
abdesselam

VCRUNTIME140.dll Fehler

Dieser Fehler bedeutet, dass Sie keine erforderlichen Visual C++ - Pakete auf Ihrem Computer installiert haben. Wenn Sie wampserver installiert haben, deinstallieren Sie zunächst wampserver.

Lade die VC Pakete herunter

Laden Sie alle diese VC -Pakete herunter und installieren Sie sie alle. Sie sollten sowohl die 64-Bit- als auch die 32-Bit-Version installieren. 

- VC9-Pakete (Visual C++ 2008 SP1) --
http://www.Microsoft.com/de-de/download/details.aspx?id=5582
http://www.Microsoft.com/de-de/download/details.aspx?id=2092

-- VC10-Pakete (Visual C++ 2010 SP1) --
http://www.Microsoft.com/de-de/download/details.aspx?id=8328
http://www.Microsoft.com/de-de/download/details.aspx?id=13523

-- VC11-Pakete (Visual C++ 2012 Update 4) -
Die beiden Dateien VSU4\vcredist_x86.exe und VSU4\vcredist_x64.exe, die heruntergeladen werden sollen, befinden sich auf derselben Seite 
http://www.Microsoft.com/de-de/download/details.aspx?id=30679

-- VC13-Pakete] (Visual C++ 2013) -
Die beiden Dateien VSU4\vcredist_x86.exe und VSU4\vcredist_x64.exe, die heruntergeladen werden sollen, befinden sich auf derselben Seite
https://www.Microsoft.com/de-de/download/details.aspx?id=40784

- VC14-Pakete (Visual C++ 2015) -
. Die beiden Dateien vcredist_x86.exe und vcredist_x64.exe, die heruntergeladen werden sollen, befinden sich auf derselben Seite
http://www.Microsoft.com/de-de/download/details.aspx?id=48145

Installationspakete mit Administratorrechten
Rechtsklick-> Als Administrator ausführen

wampserver erneut installieren
Nachdem Sie sowohl die 64-Bit- als auch die 32-Bit-Version von VC - Paketen installiert haben, installieren Sie den Wampserver erneut.

9
Harun ERGUL

Bevor Sie WAMP installieren, müssen Sie einige Visual C++ - Pakete installieren (wenn Sie es installiert haben, müssen Sie es deinstallieren und erneut installieren).

Sie benötigen: VC9, VC10, VC11, VC13 und VC14

In readme.txt von wampserver 3 (auf SourceForge) finden Sie die Links.

Achtung! Wenn Sie ein 64-Bit-Betriebssystem verwenden, müssen Sie beide Versionen jedes Pakets installieren.

9
Oriol Tauleria

Ich hatte das gleiche Problem und habe es mit der Installation gelöst:

NB: 64-Bit-Installation war genug, ich musste Wamp danach deinstallieren/neu installieren

3
ccarrez

Da Sie bereits eine laufende WAMP-Version installiert haben und diese nicht mehr funktioniert, haben Sie wahrscheinlich VCRUNTIME140.dll bereits installiert. In diesem Fall:

  1. Öffnen Sie Programme und Funktionen
  2. Klicken Sie mit der rechten Maustaste auf die entsprechenden Installationsprogramme für Microsoft Visual C++ 20xx Redistributable, und wählen Sie "Ändern".
  3. Wählen Sie "Reparieren". Tun Sie dies sowohl für x86 als auch für x64

Das hat den Trick für mich gemacht.

2
David Niki

Nachdem ich jeden Tag viel installiert und deinstalliert und jedes Paket für jede Antwort ausprobiert hatte, war das einzige, was für mich funktionierte:

  1. Deinstalliere Wamp und starte neu
  2. installieren Sie die Visual Studio 2017 Community Edition, wählen Sie "Webentwicklung" und überprüfen Sie alle Optionen auf der richtigen Site. Hier ist ein Screenshot:  enter image description here

Installieren Sie etwas, das auch für Wamp benötigt wird.

  1. installieren Sie Wamp, und Sie sollten alle gut sein.

Link zu visual studio 2017 Community Edition

0
Rami Nour

WAMP wird nicht GRÜN? Keine Panik

Überprüfen Sie zunächst Ihr Windows-Update, indem Sie "Windows Update" suchen.

oder

Laden Sie Updates von der Microsoft Windows-Site herunter (Windows 7 x64 wurde auf Service Pack 1 aktualisiert) Windows 7 Service Pack 1 Download

Nun gibt es einige weitere Downloads, die WAMP für die Installationszeit unterstützen

Aus der readme.txt

Bevor Sie mit der Installation von Wampserver fortfahren, müssen Sie sicherstellen, dass dass bestimmte Elemente auf Ihrem System installiert sind, andernfalls Wampserver läuft absolut nicht und außerdem die Installation wird fehlerhaft sein und Sie müssen Wampserver entfernen, BEVOR Sie das .__ installieren. Elemente, die fehlten.

Stellen Sie sicher, dass Sie in den weitervertreibbaren Paketen VC9, .__, auf dem neuesten Stand sind. VC10, VC11, VC13 und VC14 Auch wenn Sie glauben, dass Sie auf dem neuesten Stand sind, Installieren Sie jedes Paket als Administrator. Wenn die Meldung "Bereits installiert" angezeigt wird, überprüfen Sie Repair.

Die folgenden Pakete (VC9, VC10, VC11) sind zwingend erforderlich für Wampserver 2.4, 2.5 und 3.0, auch wenn Sie nur Apache und PHP .__ verwenden. Die Versionen VC11 und VC14 sind für PHP 7 und Apache 2.4.17 erforderlich

VC9-Pakete (Visual C++ 2008 SP1) https://www.Microsoft.com/de-de/download/details.aspx?id=5582https://www.Microsoft.com/de-de/download/details.aspx?id=2092

VC10-Pakete (Visual C++ 2010 SP1) https://www.Microsoft.com/de-de/download/details.aspx?id=8328https://www.Microsoft.com/de-de/download/details.aspx?id=13523

VC11-Pakete (Visual C++ 2012 Update 4) Die beiden Dateien VSU4\vcredist_x86.exe und VSU4\vcredist_x64.exe zum Herunterladen stehen auf die gleiche Seite: http://www.Microsoft.com/de-de/download/details.aspx?id=30679

VC13-Pakete [/ b] (Visual C++ 2013) Die beiden Dateien VSU4\vcredist_x86.exe und VSU4\vcredist_x64.exe

VC14-Pakete (Visual C++ 2015) Die beiden Dateien vcredist_x86.exe und vcredist_x64.exe muss auf derselben Seite heruntergeladen werden: https://www.Microsoft.com/de-de/download/details.aspx?id=52685

VC-Pakete x64 (Visual C++ 2017)

https://support.Microsoft.com/de-de/help/2977003/the-latest-supported-visual-c-downloads

0
Bhavsar1311