it-swarm.com.de

Der richtige Weg, um RxJS auf die neueste Version zu aktualisieren

Beim Versuch, die neueste Version von RxJS zu installieren,

Ich habe npm install rxjs wie in dieser Dokumentation beschrieben verwendet: https://github.com/reactivex/rxjs

Aber ich habe diese Warnungen bekommen:

npm warn @ angle/common @ 5.1.0 erfordert einen Peer von [email protected]^5.5.0, aber keiner ist installiert.

Sie müssen Peer-Abhängigkeiten selbst installieren.

 enter image description here

Es sieht also so aus, als ob RxJS aktualisiert wird, aber nicht auf die neueste Version.

In der Ausgabe sehen wir, dass es eine neueste Version gibt, nämlich RxJS 5.5.0

Gibt es eine bessere npm-Befehlszeile, um auf die neueste Version zu aktualisieren?

2
HDJEMAI

Sie können immer versuchen, die Version zu erzwingen 

npm install -g [email protected]

Oder Sie können einen moderneren Ansatz haben und Garn verwenden :)

HINWEIS

Seit der Veröffentlichung von npm 5.x ist der Kommentar zum Thema Garn nicht mehr unbedingt richtig. :)

7
Hugo Noro

Npm sagt Ihnen, dass es die neueste Version 5.5.0 gefunden hat, Ihre Version mit Winkel 5.1 ist jedoch nicht mit [email protected] kompatibel und fällt daher auf die letzte kompatible Version zurück. Aktualisieren Sie Ihre Winkelversion gleichzeitig, sodass Sie die Funktionen beider nutzen können. Sie können den neuesten Winkel mit npm install -g @angular/[email protected] .__ installieren. Nach der Installation müssen Sie npm update in Ihrem Projekt ausführen

0
mobby