it-swarm.com.de

Der Angular Compiler erfordert TypeScript> = 2.7.2 und <2.8.0, es wurde jedoch 2.8.3 gefunden

Ich bekomme diesen Fehler in meiner Angular App:

Der Angular Compiler erfordert TypeScript> = 2.7.2 und <2.8.0, jedoch 2.8.3 wurde stattdessen gefunden

und wenn ich versuche, TypeScript auf die richtige Version herunterzuregeln:

npm install -g [email protected] sagt, dass 1 Paket aktualisiert wurde.

wenn ich die TypeScript-Version mit npm view TypeScript version.__ verifiziere, bekomme ich immer noch 2.8.3

Ich habe sogar versucht, TypeScript vollständig mit npm uninstall -g TypeScript zu entfernen.

wenn ich jedoch die TypeScript-Version erneut verifiziere npm view TypeScript version bekomme ich immer noch 2.8.3

Wie lauten die Befehle, um TypeScript ordnungsgemäß auf eine frühere Version wie 2.7.2 zu löschen und wiederherzustellen?

Ich verwende Knoten v10.0.0 und npm v6.0.1

Wenn ich npm list -g TypeScript starte, sehe ich die korrekte Version 2.7.2, aber die Version 2.8.3 ist irgendwie global installiert

25
guilhebl

Sie sollten npm install [email protected]'>=2.7.2 <2.8.0' tun. Dadurch wird das richtige TypeScript installiert, das Ihr Projekt benötigt. Stellen Sie sicher, dass Sie dies in Ihrem Angular-Projekt ausführen. 

Unter Windows sollten Sie doppelte Anführungszeichen anstelle von einfachen Anführungszeichen verwenden.

npm install [email protected]">=2.7.2 <2.8.0"

Andernfalls erhalten Sie The system cannot find the file specified..

25
myhouse

Führen Sie in Ihrem Projektordner erneut npm install [email protected] wie folgt aus: 

Projekt von Angular v5 auf Angular v6 aktualisieren

Dann sollte es klappen.

10
knnhcn

Ich habe die nächsten Schritte gemacht:

  • package-lock.json entfernt;
  • npm install -g --save [email protected];
  • npm uninstall -g --save [email protected];
  • in package.json wurde der Abschnitt "devDependencies" mit TypeScript als "TypeScript" aktualisiert: "~ 2.7.2".

Nach allem oben in Projekt-Terminal ausführen ng dienen --open (ich habe IDEA 2018.1 verwendet).

4
Ilya Afanasyev

Bei der Installation von "@ angle/compiler-cli": "7.0.0-beta.4" wurde dieses Problem behoben Ich verwende "TypeScript": "3.0.3".

1
Demven Weir

Ich habe folgendes gemacht:

  • Löschen Sie den Ordner node_modules manuell
  • Löschen Sie die Datei package-lock.json manuell
  • Stellen Sie in der Datei package.json sicher, dass die Abhängigkeit von TypeScript als festgelegt ist

     "TypeScript": "2.7.2"
    
  • npm cache clean -f ausführen

  • führen Sie npm install aus

Diese Arbeit für mich.

1
Andres SoN

Dies liegt nur daran, dass package.json-Datei in Ihren Projekten vorhanden ist 

zB ."devDependencies": {"TypeScript": "~2.8.3" } 

und in Ihrem Rechner, auf dem die Installation von angle cli "TypeScript": "2.7.2" installiert ist.

Sie können dies mit ng -v oder ng v überprüfen.

Öffnen Sie einfach package.json aktualisieren Sie Ihre TypeScript-Version und run npm install und Sie sind fertig.

0
Deva

Führen Sie zum Aktualisieren die folgenden Befehle im Terminal aus.

  • Installieren Sie die neueste Version von NPM

    npm install [email protected] -g
    
  • Führen Sie das Audit aus

    npm audit  
    
  • Aktualisieren Sie den NPM

    npm update
    
  • Führen Sie das NPM-Ausführungsskript aus.

    npm start
    

Nun ist Ihr Compiler fertig.

Ein Downgrade auf TypeScript 2.9.2 (npm install [email protected]) und re-running ng update --all führt immer noch zu dem Fehler (zweimal):

Package "@angular/compiler-cli" has an incompatible peer dependency to "TypeScript" (requires ">=2.7.2 <2.10", would install "3.1.3"
Verified that version 2.9.2 of TypeScript was in node_modules.
0
Vipisanan

Hatte dasselbe Problem (unter vielen anderen) nach einem Update auf macOS Mojave . Dieses Problem wurde behoben, indem node_modules und package_lock.json manuell entfernt und in package.json von "TypeScript": "~ 2.7.2" in "TypeScript" geändert wurden: "~ 2.8.0" und lief npm install.

0
bakke2ooo