it-swarm.com.de

_angular_core.Version ist nach der Aktualisierung kein Konstruktor Angular 2

Ich glaube, das Problem hängt mit der Aktualisierung von Winkel 2 zusammen. Meine tatsächliche Folge von Ereignissen, die zu diesem Fehler führten, war 1. Installieren von ng2-typeahead, 2. Abrufen von Fehlern und Feststellen, dass ich FormsModule installieren musste, 3. Weitere Fehler erhalten und Npm alles aktualisieren . Die Codezeile, die in /node_modules/@angular/common/bundles/common.umd.js:3481:36 () fehlerhaft ist, ist 

/**
 * @stable
 */
var /** @type {?} */ VERSION = new _angular_core.Version('2.3.0');

NPM-Debug-Protokoll bei npm-debug.log bei Pastebin .

4
dcoli

Es gibt einen Konflikt zwischen [email protected] und [email protected] Versuchen Sie, Ihre Abhängigkeiten auf [email protected] und [email protected] zurückzusetzen, und das TypeScript sollte 2.0.3 oder höher sein.

https://github.com/angular/angular/issues/13342

1
Bruno João

versuchen Sie es mit: npm update --save und Sie haben automatisch die neuesten Versionen

0
moshe beeri