it-swarm.com.de

Ziel mit Hash-String "Android-24" konnte nicht gefunden werden

 enter image description here

Ich erhalte diese Fehlermeldung, nachdem alle Google-Bibliotheken auf 24.0.0 und die Variablen compileSdkVersion und targetSdkVersion auf 24 geändert wurden .. Wie Sie in den angefügten Bildern sehen können, habe ich alle Android N-Pakete installiert, aber es steht nur "Teilweise installiert" ". Wie kann ich das beheben?

 enter image description here

 enter image description here

9
DropArt

Zu diesem Zeitpunkt gibt es weder eine targetSdkVersion von 24 noch eine compileSdkVersion von 24. Dies sind (vermutlich) gültige Werte, wenn die nächste Android-Version ausgeliefert wird.

Für die N Developer Preview basierend auf meiner Arbeit hier verwenden Sie:

  • compileSdkVersion 'Android-N'
  • buildToolsVersion '24.0.0 rc1'
  • targetSdkVersion 'N'

Außerdem benötigen Sie Gradle 2.10 oder höher (sehen Sie Ihre gradle/wrapper/gradle-wrapper.properties-Datei oder Ihre eigenständige Gradle-Installation) und 'com.Android.tools.build:gradle:2.1.0-alpha1' (siehe die build.gradle-Datei der obersten Ebene).

20
CommonsWare

Für mich gearbeitet: 1. Installieren Sie fehlende Plattformen manuell in SDK Manager 2. Starten Sie Android Studio neu

4
Marriage

Folgendes hat für mich gearbeitet:

  • Android Studio auf den neuesten Stand gebracht
  • Starten Sie Android Studio neu
  • AS bietet Optionen zum Installieren fehlender Plattform-Plugins
  • Klicken Sie auf und aktualisieren Sie.
1
Venkat Kotra