it-swarm.com.de

Wie kann ich gradle in Android Studio aktualisieren?

Ich habe Android Studio 0.1.9 installiert. Heute habe ich ein Update auf Version 0.2 und natürlich ein Update erhalten. Nach der Installation habe ich Android Studio neu gestartet, aber jetzt bekomme ich folgende Meldung:

Project verwendet eine alte Version des Android-Gradle-Plug-Ins. Das Minimale unterstützte Version ist 0.5.0. Bitte aktualisieren Sie die Version von Abhängigkeit 'com.Android.tools.build:gradle'

Wie mache ich das? Ich kann keine Update-Tools für das Gradle-Plugin in Android Studio finden.

246
7heViking

Schritt 1 (Standard-Gradle-Wrapper verwenden)

Datei → Einstellungen → Erstellen, Ausführen, Bereitstellen → Erstellungstools → Gradle → Standard-Gradle-Wrapper verwenden (empfohlen)

 enter image description here

Schritt 2 (gewünschte Gradle-Version auswählen)

Datei → Projektstruktur → Projekt

 enter image description here

Die folgende Tabelle zeigt, welche Version von Gradle mit einer bestimmten Version von Android-Plugin für Gradle kompatibel ist:  Compatibility table

Neueste Versionen, die Sie mit Android Studio 3.3 (Januar 2019) verwenden können:

Plugin version: 3.3.0
Gradle version: 4.10.1

Offizielle Links

318
vovahost

Dies ist möglicherweise nicht die genaue Antwort für das OP, aber es ist die Antwort auf den Titel der Frage: So aktualisieren Sie Gradle in Android Studio (AS):

  • Holen Sie sich die neueste Version, die von AS unterstützt wird: http://www.gradle.org/downloads (Aktuell 1.9, 1.10 wird von AS noch nicht unterstützt)
  • Installation: Entpacken Sie die Datei an einem Ort, an dem AS installiert ist: C:\Users [Benutzername]\gradle-1.9 \
  • Öffnen Sie AS: File-> Settings-> Gradle-> Service-Verzeichnispfad: (Wechseln Sie in den Ordner, den Sie oben eingestellt haben) -> Klicken Sie auf OK. Der Status unten sollte anzeigen, dass er beschäftigt ist, und der Fehler sollte behoben sein. Möglicherweise muss AS neu gestartet werden
83
Kevin

nach der Veröffentlichung von Android Studio 3.0 (stabil), Popup wird angezeigt, Wenn ein Update verfügbar ist

OR

Manuell ändern Sie einfach die Version von Gradle in top-level (Projektebene) build.gradle-Datei auf den neuesten Stand.

   buildscript {
      ...
      dependencies {
        classpath 'com.Android.tools.build:gradle:3.0.0'
      }
    }

überprüfen sie die tabelle

The Android Gradle Plugin and Gradle

 Android Gradle Plugin            Requires Gradle
 1.0.0 - 1.1.3                    2.2.1 - 2.3
 1.2.0 - 1.3.1                    2.2.1 - 2.9
 1.5.0   2.2.1+                   2.2.1 - 2.13
 2.0.0 - 2.1.2                    2.10  - 2.13
 2.1.3 - 2.2.3                    2.14.1+
 2.3.0+                           3.3+
 3.0.0+                           4.1+    
 3.1.0+                           4.4+    
 3.2.0 - 3.2.1                    4.6+    
 3.3.0 - 3.3.1                    4.10.1+ 

check gradle revisionen

39
Amit Vaghela

Öffnen Sie Datei> Projektstruktur> Registerkarte Projekt.

 enter image description here

Android Studio verfügt über ein integriertes project structure-Menü, um die im aktuellen Projekt verwendeten Einstellungen und Plugins zu überprüfen und zu aktualisieren.

Auf der folgenden Website wird ausführlich beschrieben, wie gradle und gradle plugin von Android Studio aktualisiert werden. 

Aktualisieren Sie das Plug-In für Android Studio

27
Jayakrishnan PM

Für diejenigen, die immer noch dieses Problem haben (zum Beispiel zum Wechseln von 2.8.0 auf 2.10.0), wechseln Sie in die Datei gradle-wrapper.properties und setzen Sie distributionUrl auf ähnliche Weise. 

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.Zip

Ich habe 2.8.0 auf 2.10.0 geändert und vergesse nicht, danach zu synchronisieren

6
Cedriga

Öffnen Sie Ihre build.gradle-Stammdatei und ändern Sie die Gradle-Version auf diese Weise

Alte Version:

 dependencies {
        classpath 'com.Android.tools.build:gradle:1.3.0'
    } 

Neue Version:

dependencies {
        classpath 'com.Android.tools.build:gradle:1.5.0'
    }

Für die Kompatibilität der Gradle-Version siehe dies.

4
Venu

Öffnen Sie unter Mac terminal und führen Sie die folgenden Befehle gemäß Anweisungen aus:

$ curl -s https://get.sdkman.io | bash

dann

$ sdk install gradle 3.0

Wenn die Installation abgeschlossen ist, fragt das Terminal, ob es als Standardversion festgelegt werden soll. Geben Sie also y ein und geben Sie es als Standardversion an. 

Öffnen Sie nun Android Studio -> Terminal und führen Sie den folgenden Befehl aus

Gradle --version
4
zeeawan

Kann ich noch nicht kommentieren.

Wie Kevin, jedoch mit unterschiedlichem UI-Schritt:

Dies ist möglicherweise nicht die genaue Antwort für das OP, aber es ist die Antwort auf den Titel der Frage: So aktualisieren Sie Gradle in Android Studio (AS):

  • Holen Sie sich die neueste von AS unterstützte Version: http://www.gradle.org/downloads (Derzeit wird 1.9, 1.10 noch nicht von AS unterstützt).
  • Installation: Entpacken Sie die Datei an einem Ort, an dem AS installiert ist: C:\Users [Benutzername]\gradle-1.9 \
  • Öffnen Sie AS: File-> Settings-> Build, Execution, Deployment-> Build Tools-> Gradle-> Service-Verzeichnispfad: (Wechseln Sie in den Ordner, den Sie oben eingestellt haben) -> Klicken Sie auf OK. Der Status unten sollte anzeigen, dass er beschäftigt ist, und der Fehler sollte behoben sein. Möglicherweise muss AS neu gestartet werden
2
QiMata

Gehen Sie zu Datei> Einstellungen> Builds, Ausführung, Bereitstellung> Build-Tools> Gradle> Gradle-Home-Pfad

Legen Sie jetzt Use default gradle wrapper und bearbeiten Sie das Feld projectUllelewrapper\gradle-wrapper.properties so auf

distributionUrl = https: //services.gradle.org/distributions/gradle-2.10-all.Zip

2
Ashish Kapil

Für mich habe ich meinen Schriftartenordner von den Assets in den res-Ordner kopiert und das Problem verursacht, weil Android Studio Großbuchstaben nicht akzeptierte. Ich wechselte in den Projektansichtsmodus und löschte ihn, fügte sie dann als Schriftartressourcendatei hinzu, indem Sie mit der rechten Maustaste auf den Ordner res klicken.

0
fullMoon

Für mich geht das:

gehen Sie einfach zu "/home/your-user/.gradle/wrapper/dists/"

lösche alles darin

Es wird durch Android Studio ersetzt

auf Terminal-Lauf: ionische Emulation von Android

Es ist alles ...

0
Tom Costa

In den meisten Fällen kann Android Studio das Gradle-Plugin automatisch aktualisieren.

Wenn Ihre Gradle-Plugin-Version hinterher ist, funktioniert Instant Run meistens nicht. Wenn Sie also zu den Instant Run-Einstellungen wechseln (Voreinstellungen> Erstellen, Ausführen, Bereitstellung> Instant Run), wird oben rechts die Schaltfläche Projekt aktualisieren angezeigt (Abbildung unten). Wenn Sie hierauf klicken, werden sowohl der Gradle-Wrapper als auch die Build-Tools aktualisiert  Update Project

0
Mehmet K