it-swarm.com.de

So richten Sie die Jetpack-Navigation mit material.BottomNavigationView ein

Ich kann die Navigationskomponente nicht mit com.google.Android.material.bottomnavigation.BottomNavigationView einrichten. Es wird ein Fehler ausgegeben.

enter image description here

Hier ist der Code, den ich versuche zu verwenden

 // Setup bottom navigation view
    NavigationUI.setupWithNavController(
            bottom_navigation_view,
            findNavController(R.id.main_nav_Host_fragment)
    )

wenn ich die NavigationUI -Klasse öffne, stelle ich fest, dass sie nur die alte Android.support.design.widget akzeptiert. BottomNavigationView , aber ich möchte die neue com.google.Android.material.bottomnavigation.BottomNavigationView -Klasse verwenden. Irgendeine Idee dazu?

9
Pedro Massango

Ich benutze diese Bibliotheken

implementation 'androidx.appcompat:appcompat:1.0.0-beta01'
// Architecture Components
def nav_version = "1.0.0-alpha02"
implementation "Android.Arch.navigation:navigation-fragment-ktx:$nav_version"
// use -ktx for Kotlin
implementation "Android.Arch.navigation:navigation-ui-ktx:$nav_version"

und das ist meine Aktivität

NavigationUI.setupWithNavController(bottomNavView, 
Navigation.findNavController(this, R.id.nav_Host_fragment))

und das ist mein layout

<?xml version="1.0" encoding="utf-8"?>
<androidx.coordinatorlayout.widget.CoordinatorLayout  xmlns:Android="http://schemas.Android.com/apk/res/Android"
xmlns:app="http://schemas.Android.com/apk/res-auto"
xmlns:tools="http://schemas.Android.com/tools"
Android:layout_width="match_parent"
Android:layout_height="match_parent"
tools:context=".ui.main.ActivityMain">

<fragment
    Android:id="@+id/nav_Host_fragment"
    Android:name="androidx.navigation.fragment.NavHostFragment"
    Android:layout_width="match_parent"
    Android:layout_height="match_parent"
    app:defaultNavHost="true"
    app:navGraph="@navigation/nav_graph" />

<com.google.Android.material.bottomnavigation.BottomNavigationView
    Android:id="@+id/bottomNavView"
    Android:layout_width="match_parent"
    Android:layout_height="wrap_content"
    Android:layout_gravity="bottom"
    app:menu="@menu/menu_nav_drawer" />

<com.google.Android.material.floatingactionbutton.FloatingActionButton
    style="@style/Widget.MaterialComponents.FloatingActionButton"
    Android:layout_width="wrap_content"
    Android:layout_height="wrap_content"
    Android:layout_gravity="bottom|end"
    Android:layout_marginEnd="@dimen/dimen_16"
    Android:layout_marginBottom="72dp"
    app:fabSize="normal"
    tools:srcCompat="@drawable/ic_add_white" />

</androidx.coordinatorlayout.widget.CoordinatorLayout>
4
Summer-Yang

Bitte aktualisieren Sie "Android.Arch.navigation: navigation-ui: 1.0.0-alpha03", um dieses Problem zu beheben

NavigationUI aktualisiert

In der Navigationsdokumentation nachschlagen: https://developer.Android.com/topic/libraries/architecture/adding-components#navigation Stand 29. Juni 2018.

Es sagt:

Blockquote-Navigationsklassen sind bereits im androidx.navigation-Paket enthalten, hängen jedoch derzeit von der Support Library 27.1.1 und den zugehörigen Arch-Komponentenversionen ab. Die Version von Navigation mit AndroidX-Abhängigkeiten wird in Zukunft veröffentlicht.

Im Moment haben Sie wohl keine andere Wahl, als auf eine "zukünftige" Veröffentlichung des Navigationspakets zu warten.

Wie von @Levi Albuquerque vorgeschlagen, müssen Sie vorerst com.Android.support:design:28.0.0-alpha3.
Es sollte genauso funktionieren com.google.Android.material:material:1.0.0-alpha3 tut.

0
Lucas S.