it-swarm.com.de

React Native Gradle ImagePicker wird nicht erstellt

Wenn ich versuche zu bauen, erhalte ich folgende Fehlermeldung: 

Es wurden keine Übereinstimmungen für com.Android.tools.build:gradle:2.2.+ gefunden, da keine Versionen von com.Android.tools.build:gradle verfügbar sind . An folgenden Orten gesucht: https://jcenter.bintray.com/com/Android/tools/build/gradle/maven-metadata.xmlhttps://jcenter.bintray.com/com/Android/tools/build/gradle/ Benötigt von: Projekt: Reaktiver Bildwähler

Wenn ich jedoch die Werkzeugversion in Project gradle.build in 2.2.3 ändere, erhalte ich diesen Fehler 

Die Methodenimplementierung () für Argumente [Verzeichnis 'libs'] für das Objekt org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler konnte nicht gefunden werden.

6
georgcon

Sie schickten eine neue Version und alles wurde behoben. [email protected]

1
georgcon

Bearbeiten Sie Ihr build.gradle wie folgt.

subprojects { subproject ->
    if (subproject.name.contains('react-native-image-picker')){
        buildscript {
            repositories {
                maven { url "https://dl.bintray.com/Android/android-tools/"  }
            }
        }
    }
}
2
John Miller

fügen Sie dies zu build.gradle hinzu.

Ich denke, mein Problem ist, weil sie eine neue Veröffentlichung geschickt haben.

Es kann Vektor-Icons und ein Bild-Picker-Problem beheben

subprojects {
    if (project.name.contains('react-native-image-picker') ||
        project.name.contains('react-native-vector-icons')) {
        buildscript {
            repositories {
                jcenter()
                maven { url "https://dl.bintray.com/Android/android-tools/"  }
            }
        }
    }
}
0
John Miller