it-swarm.com.de

"Nicht unterstützte Vorlagenabhängigkeit: Aktualisieren Sie Ihr Android Eclipse-Plugin" mit SDK Tools v22

Ich habe kürzlich meine Android SDK Tools auf Version 22 aktualisiert. Wenn ich jedoch ein neues Projekt in Eclipse erstellen möchte, wird eine Fehlermeldung angezeigt:

Nicht unterstützte Vorlagenabhängigkeit: Aktualisieren Sie Ihr Android Eclipse-Plugin

Wie kann ich dieses Problem beheben?

26
Swapnil Ghosh

Laden Sie es von http://dl-ssl.google.com/Android/repository/tools_r22-windows.Zip herunter, entpacken Sie es und ersetzen Sie den Ordner/tools durch diesen Ordner, um die SDK-Tools herunterzurechnen. In Version 22 ist ein Fehler aufgetreten.

Für Mac http://dl-ssl.google.com/Android/repository/tools_r22-macosx.Zip

Für Linux: http://dl-ssl.google.com/Android/repository/tools_r22-linux.Zip

24
lulu88

Das Projektmitglied hat comment # 55 veröffentlicht, das dieses Problem löst, ohne die SDK-Tools herunterzuladen. Laden Sie einfach die activity-Templates herunter und ersetzen Sie den Ordner sdk/tools/templates/activities durch den Inhalt der Zip-Datei.

Möglicherweise müssen Sie Eclipse mit der Option -clean neu starten, damit Eclipse funktioniert.

6
M.Sameer

Gehen Sie in Eclipse zu Hilfe> Nach Updates suchen und installieren Sie alle von Eclipse angezeigten Updates. 

Nachdem Sie die SDK-Komponenten aktualisiert haben, müssen Sie normalerweise auch die Eclipse-Plugins aktualisieren. 

1
Boardy

Mit dem gleichen Problem habe ich gestern angefangen, als ich auf die neuesten Android SDK-Tools (22.2) aufgerüstet habe. Also habe ich die Änderungen rückgängig gemacht und benutze jetzt Android SDK Tool (22.0.5) und es funktioniert gut. 

Versuchen Sie, Android SDK-Tools herunterzurüsten.

0
Deepak Agrawal