it-swarm.com.de

Mit 0.4.3 Android Studio, Fehler: "Gradle-Projektsynchronisierung ist fehlgeschlagen. Grundlegende Funktionen (z. B. Bearbeiten, Debuggen) funktionieren nicht ordnungsgemäß."

Ich habe festgestellt, dass mehrere Personen nach dem Upgrade auf Android Studio 0.4.3 Probleme haben (Problem mit 0.4.2, glaube ich auch). Meine Fehler- und Debug-Schritte lauten wie folgt:

Die folgende Meldung wird angezeigt: "Die Synchronisierung des Projekts" Gradle "ist fehlgeschlagen. Die grundlegenden Funktionen (z. B. Bearbeiten, Debuggen) funktionieren nicht ordnungsgemäß", wie in Momentaufnahme unten gezeigt.

Error in Android Studio

Ich habe diesen Thread und folgende Anweisungen gefunden, aber ich habe immer noch den Fehler. Ich kann die folgende Anweisung im Thread nicht ausführen: Ich ging in die Gradle-Einstellungen und klickte auf "use local Gradle distribution" und zeigte auf *: C: /Users/robot_000/.gradle /wrapper/dists/gradle-1.10-all/6vpvhqu0efs1fqmqr2decq1v12/gradle-1.10

Muss ich eine lokale Verteilung von Gradle haben? Wo lade ich es herunter und wo stecke ich es ab? Wie kann ich jetzt Android Studio mitteilen, dass es verwendet werden soll? (Wie Sie sehen können, verstehe ich nicht, wie Gradle funktioniert). Danke für jede Hilfe.

Update 1: Ich habe die Gradle-Dateien auf meinem Computer unter C:\Users\home.gradle\wrapper\dists\gradle-1.10-all\6vpvhqu0efs1fqmqr2decq1v12\gradle-1.10 gefunden, aber wie mache ich das? Dies: "ging in Gradle-Einstellungen und klickte auf" lokale Gradle-Verteilung verwenden "und verwies es auf *" (gemäß THISAD )

25
user1406716

Gehen Sie zu "Datei"> "Einstellungen"> "Gradle". Am Ende dieses Bildschirms können Sie Ihre Gradle einrichten:

gradle setting

Vergewissern Sie sich außerdem, dass sich das Google Repository in Ihrem Android SDK-Verzeichnis befindet, das sich unter folgender Adresse befindet:

$SDK_DIR\extras\google\m2repository\com\google\Android\gms\play-services\3.1.36

Falls nicht, installieren Sie es zuerst über SDK-Manager> Extras> Google Repository.

BEARBEITEN:

Alle Ihre build.gradle (Wenn Sie die Root-Ebene build.gradle verwenden, um die Android-Gradle-Plugin-Version zu definieren, aktivieren Sie diese nur.) Muss auf 0.8-Version (spätestens ab jetzt) ​​des Android-Gradle-Plugins verweisen

 dependencies {
     classpath 'com.Android.tools.build:gradle:0.8.+'
 }

AKTUALISIERTE :

Zuordnung ist:

 | Android Gradle Plugin |  Gradle Version |
       0.7.+                     1.9
       0.8.+                     1.10
12
pyus13

Ich hatte das gleiche Problem und die Verwendung der lokalen Gradel-Distribution funktionierte auch nicht für mich. Ich fand die Lösung hier Gradle DSL-Methode nicht gefunden: 'runProguard'

Alles, was über der Gradle-Version 0.14.0 liegt, muss minifyEnabled anstelle von runProguard in Ihrer Projektdatei build.gradle verwenden. So sollte es aussehen:

buildTypes {

    release {

        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.txt'
    }
}

Hoffe das hilft. Überprüfen Sie den Link, wenn Sie immer noch verwirrt sind

4
jojobrovado

Datei -> Cache ungültig machen/neu starten

Funktioniert manchmal dafür 

4
Ryan Heitner

Ich stieß auf dieses Problem und stellte fest, dass ich bereits die Position von Gradle festgelegt hatte und das Google Repository bereits installiert hatte, wie von pyus13 erwähnt.

Meine Lösung bestand darin, Android SDK Build-Tools auf eine vorherige Version umzustellen, das Problem wurde behoben. Die letzte Überarbeitung war 19.1, aber die Aktualisierung darauf brach die Werkzeugkette.

Es könnte genauso einfach sein wie das Testen anderer Build-Tools.

SDK Platform-tools and SDK Build-tools

2
Kyle Falconer

Im Rahmen des Projekts sollten Sie in der Gradel-Eigenschaftendatei Folgendes hinzufügen:

org.gradle.jvmargs=-Xmx1024m
0
DvxWifiScan

Nun, ich weiß nicht, was für sie funktioniert hat, aber für mich arbeitete ich daran, ein paar kleine Skripte zu build.gradle ..__ hinzuzufügen.

buildscript {
    repositories {
    mavenCentral()
}
dependencies {
    classpath 'com.Android.tools.build:gradle:0.11.2'
}
}

DANN: In buildToolsVersion hatte ich eine Version 19.1.0 und dort wurden Build-Tools (SDK-Manager), Version 19.1 und 19 installiert.

Und du solltest gut gehen, hoffe es hilft jemandem .. 

0
Sindri Þór