it-swarm.com.de

Methode apt () konnte nicht gefunden werden

Ich versuche mit Dagger2 zu arbeiten, ich verwende Android Studio 2.2.2 , Aber ich habe einen Fehler mit gradle: 

Error:(34, 0) Could not find method apt() for arguments
[com.google.dagger:dagger-compiler:2.6] on object of type
 org.gradle.api.internal.artifacts.dsl.dependencies.DefaultDependencyHandler.
<a href="openFile:C:\Users\edi.bershatsky\Google
Drive\Android\eWave\MyCode\MyDagger2\app\build.gradle">Open File</a>

bitte hilf mir zu verstehen, was mit meinem gradle los ist

das ist mein projekt gradle:

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:2.2.2'
        classpath 'com.neenbedankt.gradle.plugins:Android-apt:1.8'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        mavenCentral()
        maven{
            url 'https://oss.sonatype.org/content/repositories/snapshots/'
        }
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

das ist mein modul gradle:

    apply plugin: 'com.Android.application'

Android {
    compileSdkVersion 25
    buildToolsVersion "25.0.2"
    defaultConfig {
        applicationId "com.edi.mydagger2"
        minSdkVersion 15
        targetSdkVersion 25
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "Android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-Android.txt'), 'proguard-rules.pro'
        }
    }


}

ext {
    JUNIT_VERSION = '4.12'
    DAGGER_VERSION ='2.4'
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.Android.support:appcompat-v7:25.1.1'

    compile 'com.google.dagger:dagger:2.6'
    apt 'com.google.dagger:dagger-compiler:2.6'
}
5
ediBersh

Hinzufügen

compile 'com.google.dagger:dagger:2.6'
annotationProcessor "com.google.dagger:dagger-compiler:2.6"

in Abhängigkeiten

HINWEIS:

Mit dem Android Gradle Plugin-Release 2.2.0 wird das Android-apt-Plugin nicht mehr für die Anmerkungsverarbeitung benötigt. Die apt-Funktion wurde in das neueste Android Gradle-Plugin aufgenommen, das AnnotationProcessor genannt wurde.

19
abdullahselek

Verwenden Sie annotationProcessor anstelle von apt

4
shmakova

benutzen 

compile 'com.google.dagger:dagger:2.19'
annotationProcessor "com.google.dagger:dagger-compiler:2.19"

in deinen Abhängigkeiten statt

 compile 'com.google.dagger:dagger:2.19'
 apt 'com.google.dagger:dagger-compiler:2.19'
3
felhi

Sie haben vergessen, das Android-apt-Plugin zu installieren 

 apply plugin: 'com.neenbedankt.Android-apt'

(aber jetzt sollten Sie es einfach entfernen und annotationProcessor oder kapt mit kotlin-kapt verwenden, abhängig von Ihrer Sprache) 

1
EpicPandaForce

annotationProcessor kann nicht funktionieren, wenn Sie die Option in Android Studio nicht aktiviert haben. Um dies zu tun:

Schließen Sie Ihr Projekt, klicken Sie auf Konfigurieren rechts unten, dann Einstellungen > Erstellen, Ausführen, Bereitstellen > Compiler > Anmerkungsprozessoren und tick Annotationsverarbeitung aktivieren .

Dann können Sie annotationProcessor "com.google.dagger:dagger-compiler:X.X" verwenden.

0
Omar Aflak