it-swarm.com.de

Gradle Fehler beim Update auf Android Studio 3.2

Ich habe meine Android Studio Version auf 3.2 aktualisiert. Jetzt sehe ich folgenden Fehler für mein Projekt - com.novoda.gradle.release.AndroidLibrary$LibraryUsage.getDependencyConstraints()Ljava/util/Set;

Zur Zeit verwende ich gradle Version 4.6 . Issue link https://github.com/novoda/bintray-release/issues/177 sagt Gradle-Version auf 4.4 herunterstufen, aber mindestens unterstützte Version für Android Studio 3.2 ist 4,6.

So beheben Sie diesen Fehler.

7
nikhil bansal

Ich habe den gleichen Fehler behoben, indem ich die Reihenfolge der Plugins in Ihrer build.gradle-Datei folgendermaßen geändert habe: 

//has to be BEFORE 'com.Android.library'
apply plugin: 'com.novoda.bintray-release' 
apply plugin: 'com.Android.library'

Die Lösung ist hier angegeben - Schauen Sie sich an: Ausgabe III .

Während der distributionUrl=https\://services.gradle.org/distributions/gradle-4.6-all.Zip in meiner gradle-wrapper.properties -Datei bleibt.

22
R13mus

Diese Lösung hat für mich funktioniert: Da Bintray das Problem in seiner neuen Version behoben hat, d. H. 0.9, so dass das Hinzufügen in build.gradle-Dateien (Projektdateien) den Fehler beseitigt.

klassenpfad 'com.novoda: bintray-release: 0.9'

2

Sie müssen entweder ein Downgrade auf AS 3.1.x durchführen oder die im Novoda-Problem beschriebenen Abhilfemaßnahmen durchführen. Nämlich dieses Plugin ...

0
OceanLife