it-swarm.com.de

Das Modul `DatePickerIOS` ist in der Haste-Modulzuordnung nicht vorhanden

Beim Ausführen der ReactNative Android-App wird die folgende Ausnahme und auch beim Bundle die gleiche Ausnahme angezeigt.

reaktives Paket --platform Android --dev false --entry-file index.js --bundle-output Android/app/src/main/assets/index.Android.bundle --assets-dest Android/app/src/main/res /

Modul DatePickerIOS kann nicht von Project_Path/node_modules/react-native/Libraries/react-native/react-native-implementation.js aufgelöst werden: Modul DatePickerIOS ist nicht in der Haste-Modulzuordnung vorhanden.

Helfen Sie mir bitte, das zu lösen.  enter image description here

Package.json: "Abhängigkeiten": { "reagieren": "16.3.1", "reaktionsnativ": "0.55.2", "Reaktiv-native-Kalender": "1.17.7", "reag-native-carousel-view": "0.5.1", "Reaktiver Bestätigungscode-Eingang": "1.0.4", "reag-native-dash": "0.0.8", "Reaktiv-native Elemente": "0.19.1", "React-native-fbsdk": "0.7.0", "React-native-google-places-autocomplete": "1.3.6", "Reaktiv-Native-Google-Anmeldung": "1.0.16", "React-native-i18n": "2.0.12", "Reaktiv-native-Indikatoren": "0.12.0", "Reaktiv-native-Maps": "0.21.0", "reag-native-material-bottom-navigation": "0.9.0", "reaktives Material-Dropdown": "0.11.1", "React-native-material-ui": "1.22.1", "reag-native-modalbox": "1.4.2", "reag-native-searchbar": "1.14.0", "reag-native-sensitive-info": "5.1.0", "reag-native-splash-screen": "3.0.6", "Reaktiv-native-Vektor-Icons": "4.6.0", "reag-navigation": "1.5.11", "Reaktiv-native-Tab-Ansicht": "0.0.77", "Reaktiv-native-globale-Requisiten": "1.1.3" }

8
Tech Mahesh

Beenden Sie den Vorgang im Metro-Bundler-Terminalfenster und anschließend, wie im Kommentarlauf angegeben, npm start -- --reset-cache

18
AndrewHenderson

Was ist mit mir für dieses Problem passiert,

Ich bin zweimal auf dieses Problem gestoßen.

beim ersten Import habe ich versehentlich ein js-Paket importiert, als es nicht installiert war. Es wurde durch Entfernen der falschen Importanweisung behoben

zum zweiten Mal habe ich versucht, das Paket "React-native-modal-overlay" zu installieren. Statt npm install zu verwenden, habe ich Farn hinzugefügt.

und ich fing an, dieses Problem zu bekommen

ich habe alle Schritte ausprobiert, die ich im Internet finden konnte, aber nicht aufgelöst. Schließlich nahm ich eine neue Repository-Installation in einem anderen Paket vor

- Dann habe ich npm cache clean ausgeführt (das Ergebnis bat den Befehl 'npm install --cache /tmp/empty-cache'--

1

wenn oben akzeptierte Antwort funktioniert in diesem Fall nicht. einfach verwenden

npm install DatePickerIOS

Das obige Problem kann bei jeder lib auftreten und kann einfach verwendet werden 

npm install "Error module name"
0
Rajesh Nasit