it-swarm.com.de

com.google.Android.gms: Play-Services-Messbasis wird von verschiedenen anderen Bibliotheken angefordert

Ich habe ein Upgrade auf Gradle 4.0.1 durchgeführt und erhielt folgenden Fehler

Die Bibliothek com.google.Android.gms: play-services-Measurement-Base lautet von verschiedenen anderen Bibliotheken unter [[15.0.4,15.0.4]] angefordert, aber löst sich auf 15.0.2 auf. Deaktivieren Sie das Plugin und überprüfen Sie Ihre Abhängigkeiten Baum mit ./gradlew: app: Abhängigkeiten.

Mein Projekt verwendet diese Abhängigkeit nicht, also habe ich global danach gesucht, und es kommt nur innerhalb von

build/intermediates/lint-cache/maven.google/de/google/Android/gms/group-index.xml

als diese Linie

<play-services-measurement-base versions="15.0.0,15.0.2"/>

Also habe ich versucht, meinen Build-Ordner zu löschen und das Projekt zu säubern, aber es wird mit den gleichen Werten regeneriert:

104
Ilja

Das eigentliche Problem wird in der Release-Information vom 23. Mai von https://developers.google.com/Android/guides/releases#may_23_2018 behandelt

Grundsätzlich müssen Sie alle Play Services - und Firebase -Bibliotheken auf die neueste Version ( bringen, die für jede Bibliothek unterschiedlich sein kann seit Version 15 ). Sie können https://mvnrepository.com/ verwenden, um die neueste Version für jede Bibliothek zu ermitteln.

Siehe auch: https://firebase.google.com/support/release-notes/Android#2018052

157
Nico

nur funktionierende Lösung für mich:

lege es auf die Unterseite von build.gradle 

com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true
65
htw

Stellen Sie sicher, dass die Abhängigkeiten Ihrer Google Play-Dienste und Firebase-Abhängigkeiten auf dem neuesten Stand bleiben.

Überprüfen Sie auch alle Gradle-Dateien, die Modulebene und die Projektebene. Es gibt nur eine gemeinsame Version der Abhängigkeit zwischen allen Modulen. Kann gelöst werden, indem diese Versionen in Projektlevel variabel gehalten werden.

Hier finden Sie die Update-Version für Google Play-Dienste.

Neueste Google Play-Services

Hier können Sie nach Firebase-aktualisierter Version .__ suchen.

Firebase Latest

Hier finden Sie die aktualisierte Version von Firebase für Android

Firebase Android Neueste

21
abitcode

Ich habe aktualisiert 

    implementation 'com.google.Android.gms:play-services-analytics:16.0.3'

und es funktioniert für mich

8
Amine M'hamed

mein build.gradle zu ändern, funktionierte für mich wie folgt:

ext {
  googlePlayServicesVersion   = "15.0.1"
}

allprojects {
  repositories {
      mavenLocal()
      maven { url 'http://maven.google.com' }
      jcenter { url "http://jcenter.bintray.com/" }
      google()
      maven {
        // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
        url "$rootDir/../node_modules/react-native/Android"
      }

      configurations.all {
        resolutionStrategy {
            force "com.google.Android.gms:play-services-basement:$googlePlayServicesVersion"
            force "com.google.Android.gms:play-services-tasks:$googlePlayServicesVersion"
        }
      }
  }
}
6
mk7danny

In meinem Fall habe ich mit der neuesten Version von dependencies mein Problem gelöst:

'com.google.Android.gms:play-services-analytics:16.0.1'
'com.google.Android.gms:play-services-tagmanager:16.0.1'
5
Murat

Zur Liste Ihrer Abhängigkeiten hinzufügen. Jetzt müssen Sie es für die korrekte Arbeit aller Abhängigkeiten der Firebase haben:

implementation 'com.google.firebase:firebase-core:16.0.1'
3
PavelGP

Dies kann passieren, wenn Ihr Android Gradle-Plugin sehr alt ist, auch wenn Sie nur eine einzige Google-Bibliothek verwenden! Anscheinend mussten früher alle Google-Bibliotheken dieselbe Version haben. Jetzt müssen sie nicht mehr gleich sein, sondern nur noch die neuesten. Wenn Sie auch nur eine einzige Bibliothek angeben, werden Abhängigkeiten berücksichtigt, bei denen die Versionen nicht übereinstimmen, und das alte Android Gradle-Plug-in wird deaktiviert.

Setze eine neuere Version wie:

buildscript {
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.3.2'
    }
}

Möglicherweise müssen Sie Ihr Gradle aktualisieren, um das neuere Plugin zu verwenden (es wird Ihnen mitteilen).

3
NateS

Für mich ist dieser Fehler nach der Integration von Crashlytics über Firebase aufgetreten, aufgrund eines Konflikts zwischen den Versionen 

implementation 'com.google.firebase:firebase-core:16.0.4'
implementation 'com.google.Android.gms:play-services-location:15.0.1'

Ich habe zuerst versucht, Firebase Core auf 15.0.1 herunterzurüsten, aber es scheint es gibt keine solche Version, nur 15.0.0 und 15.0.2! Stattdessen musste ich beide auf die Version 15.0.0 zurückstufen, also landete ich bei 

implementation 'com.google.firebase:firebase-core:15.0.0'
implementation 'com.google.Android.gms:play-services-location:15.0.0'

Jetzt funktioniert es, aber ich bekomme die nervigen Lint-Warnungen, dass neuere Versionen verfügbar sind. Dieses Versionierungs-Debakel ist ein verdammtes Chaos.

2
Magnus W

Die einzige Lösung, die für mich funktioniert (gefunden hat wo in SOF) (habe keinen Link) ist:

in der obersten Hauptansicht von build.grale 

allprojects {

subprojects {
    project.configurations.all {
        resolutionStrategy.eachDependency { details ->
            if (details.requested.group == 'com.google.Android.gms'
                    && !details.requested.name.contains('multidex')) {
                details.useVersion "x.y.z"
            }
        }
    }
}
2
issamux

Ein ähnliches Problem trat bei mir auf, als ich versuchte, Firebase Database zu meinem Projekt hinzuzufügen.

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.3'

Das Problem kann durch ein Downgrade oder ein Upgrade beider Versionen auf ein ähnliches Level behoben werden

implementation 'com.google.firebase:firebase-core:16.0.1'
implementation 'com.google.firebase:firebase-database:16.0.1'

und es hat funktioniert! Alle verfügbaren Versionen können auf dieser Site durchsucht werden: https://mvnrepository.com/

2

Ich habe bemerkt, dass Debug-Protokolle alte Versionen von Firebase-Analytics (16.0.0) erwähnen. Durch das explizite Hinzufügen der neuesten Version wurde das Problem behoben:

implementation "com.google.firebase:firebase-analytics:16.0.3"
1
smok

Ich hatte das gleiche Problem 

Stellen Sie nur sicher, dass Sie die neuesten Versionen aller Abhängigkeiten haben. Ich habe die aktuellen Versionen für Firebase-Core und auth ..__ verwendet. Die neueren Versionen enthalten Fehlerbehebungen. 

Die neuesten Versionen finden Sie hier: https://firebase.google.com/support/release-notes/Android

Aktuelle Version zum aktuellen Zeitpunkt verwenden:

in app/build.gradle:

dependencies {
implementation 'com.google.firebase:firebase-core:16.0.6'
implementation 'com.google.firebase:firebase-auth:16.1.0'
}
1
shellym

Ich vermute, der folgende Fehler ist auf die unterschiedlichen Versionen der Firebase-Abhängigkeiten zurückzuführen. Wenn ich die Version aller Abhängigkeiten, die ich in meinem Projekt implementiere, auf 16.0.1 ändere, funktionierte es wie ein Zauber.

Für mich wurde der Fehler durch die folgende Zeile erzeugt: com.google.firebase:firebase-auth:16.0.2

Und ich habe es geändert in: com.google.firebase:firebase-auth:16.0.1

Und es hat funktioniert .. Hoffe das hilft.

1
Vipin George

Aktualisieren Sie alle Ihre Abhängigkeiten auf die neueste Version, um das Problem zu beheben.

Keine Notwendigkeit, hinzuzufügen 
com.google.gms.googleservices.GoogleServicesPlugin.config.disableVersionCheck = true

Wenn Sie gemischte Versionen verwenden, führt dies zu Abstürzen.

1
RakeshGupta

1. Öffnen Sie die Projektebene build.gradle

Aktualisieren Sie die com.google.gms:google-services-Version auf den neuesten Stand. Neueste Version verfolgen . Zum Zeitpunkt der Antwort ist 4.1.0

2. Öffnen Sie die App-Ebene build.gradle

Aktualisieren Sie die Abhängigkeit, falls Sie welche verwenden. Beachten Sie, dass die Firebase jetzt für jede Abhängigkeit eigene Versionen hat.

Verwenden Sie neueste Firebase-Bibliotheken . Zum Zeitpunkt der Antwort sind die neuesten Versionen unten.

Firebase Core                com.google.firebase:firebase-core:16.0.3
Ads                          com.google.firebase:firebase-ads:15.0.1
Analytics                    com.google.firebase:firebase-analytics:16.0.3
App Indexing                 com.google.firebase:firebase-appindexing:16.0.1
Authentication               com.google.firebase:firebase-auth:16.0.3
Cloud Firestore              com.google.firebase:firebase-firestore:17.1.0
Cloud Functions              com.google.firebase:firebase-functions:16.1.0
Cloud Messaging              com.google.firebase:firebase-messaging:17.3.2
Cloud Storage   c            om.google.firebase:firebase-storage:16.0.2
Crash Reporting              com.google.firebase:firebase-crash:16.2.0
Crashlytics                  com.crashlytics.sdk.Android:crashlytics:2.9.5
Dynamic Links                com.google.firebase:firebase-dynamic-links:16.1.1
Invites                      com.google.firebase:firebase-invites:16.0.3
In-App Messaging             com.google.firebase:firebase-inappmessaging:17.0.1
In-App Messaging Display     com.google.firebase:firebase-inappmessaging-display:17.0.1
ML Kit: Model Interpreter    com.google.firebase:firebase-ml-model-interpreter:16.2.0
ML Kit: Vision               com.google.firebase:firebase-ml-vision:17.0.0
ML Kit: Image Labeling       com.google.firebase:firebase-ml-vision-image-label-model:15.0.0
Performance Monitoring       com.google.firebase:firebase-perf:16.1.0
Realtime Database            com.google.firebase:firebase-database:16.0.2
Remote Config                com.google.firebase:firebase-config:16.0.0

Synchronisieren und erstellen ...

1
Khemraj

ersetzen Sie das "+" durch die Versionsnummer. Es würde die neueste Version auswählen.

implementation 'com.google.firebase:firebase-analytics:+'

0
Kyi Moe Min

firebase-core & firebase-database ... sollte dieselbe Version haben:

implementierung 'com.google.firebase: Firebase-Core: 16.0.1' Implementierung 'com.google.firebase: Firebase-Datenbank: 16.0.1'

0
RD QUOCVIET

Ich habe den gleichen Fehler, aber mein Fall war anders. Ich habe sowohl Audience Network als auch Firebase verwendet.

Ich habe diesen Fehler bekommen

Die Android-Abhängigkeit 'com.google.Android.gms: play-services-basement' hat unterschiedliche Versionen für den Klassenpfad compile (11.0.4) und runtime (16.0.1). Sie sollten dieselbe Version manuell über DependencyResolution festlegen

Hier ist die Lösung, wenn Sie audience-network verwenden.

implementation ("com.facebook.Android:audience-network-sdk:$rootProject.fb_version")
{
    exclude group: 'com.google.Android.gms'
}
0
Nikunj Paradva

Beim Versuch, für alles die gleiche Version zu verwenden, trat ein ähnlicher Fehler auf:

implementation 'com.google.Android.gms:play-services-base:16.0.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.0'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.0.0'
implementation 'com.google.Android.gms:play-services-gcm:16.0.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:16.0.0'

Das Problem wurde für mich behoben, als ich Folgendes tat:

1) Verwendete die neueste verfügbare Version jedes Dienstes:

implementation 'com.google.Android.gms:play-services-base:16.1.0'
implementation 'com.google.Android.gms:play-services-analytics:16.0.8'
implementation 'com.google.Android.gms:play-services-awareness:16.0.0'
implementation 'com.google.Android.gms:play-services-cast:16.2.0'
implementation 'com.google.Android.gms:play-services-gcm:16.1.0'
implementation 'com.google.Android.gms:play-services-location:16.0.0'
implementation 'com.google.firebase:firebase-messaging:17.6.0'

2) Android Studio auf die aktuellste Version aktualisiert (Android Studio 3.4).

3) Android Gradle Plugin Version auf 3.4.0 und Gradle Version auf 5.1.1 aktualisiert.

0
Jaime Montoya

Sie finden die Bibliothek in dieser Abhängigkeit, indem Sie

$ ./gradlew app:dependencies
0
Nico

Ich habe ein ähnliches Problem, das behoben wurde durch:

  1. In App Level Gradle: Aktualisieren Sie alle Firebase-Abhängigkeiten auf die neueste Version. latest
  2. Auf Projektebene Gradle: Aktualisieren Sie die Abhängigkeit auf den neuesten Stand: gms.google-services. In meinem Fall war dies: 'com.google.gms: google-services: 4.2.0'.
0
tabebqena

Hatte das gleiche Problem. Sie müssen den Doppelpunkt entfernen: nach der Version im Gradle (es ist ein Fehler).

Diese Einstellungen haben für mich funktioniert:

implementation 'com.google.firebase:firebase-firestore:17.1.5'

Setzen Sie multiDexEnabled auch in Gradle auf true (wenn Sie den DexOverflowException-Fehler erhalten):

    Android {
        compileSdkVersion 27
..
            multiDexEnabled true
        }
0
live-love

Dies kann mithilfe der neuesten Abhängigkeiten behoben werden.

Die neuesten finden Sie auf der folgenden Website

https://firebase.google.com/support/release-notes/Android#20180523

Poste diese Synchronisation erneut und es sollte gut funktionieren

0

Das gleiche Problem hatte ich, als ich versuchte, die Firebase-Datenbankimplementierung hinzuzufügen. Wenn ich kommentierte, dass die Zeile funktioniert, funktioniert das. Nach ein paar Versuchen ging ich zu https://firebase.google.com/docs/Android/setup

Dort habe ich die Versionen der verfügbaren Bibliotheken überprüft und mein Firebase-Core war auf 16.0.1 (die aktuelle Version ist 16.0.4), also habe ich sie manuell geändert und es hat gut funktioniert, Build und Sync waren erfolgreich.

0
Anibal

Ich habe dasselbe Problem, dann löste ich die Implementierung "com.google.firebase: firebase-auth: 15+" stattdessen "com.google.firebase: firebase-auth: 16.1.0"

0
altintasomer

In meinem Fall verwende ich die neueste rnfirebase unter URL

https://rnfirebase.io/docs/v4.3.x/installation/Android

füge unten in Android/app/proguard-rules.pro hinzu)

-keep class io.invertase.firebase.** { *; }
-dontwarn io.invertase.firebase.**
0
krish

hier ist eine einfache Lösung. Das Problem ist, dass Sie die neueste Version für eine Bibliothek und eine niedrigere Version für die andere Bibliothek verwenden. versuche es auszugleichen. Die beste Lösung ist, die neueste Version für alle Ihre Bibliotheken zu verwenden. Um Ihr Problem zu lösen, klicken Sie einfach auf hier und sehen Sie sich die neueste Version der Bibliotheken an. Fügen Sie sie in Ihr Projekt ein und synchronisieren Sie sie anschließend.
in meinem Fall funktioniert für mich Folgendes:

dependencies{
    implementation 'com.google.firebase:firebase-core:16.0.7'
    implementation 'com.google.firebase:firebase-database:16.1.0'
}
apply plugin: 'com.google.gms.google-services'
0
In my case

ERROR: The library com.google.Android.gms:play-services-basement is being requested by various other libraries at [[15.0.1,15.0.1]], but resolves to 16.0.1. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

It solves my issue
implementation 'com.google.Android.gms:play-services-analytics:16.0.1'
0
Kishore Reddy

In meinem Fall entferne ich einfach 

implementation "com.google.Android.gms:play-services-ads:16.0.0

und fügen Sie Abhängigkeiten für Firebase-Anzeigen hinzu 

implementation 'com.google.firebase:firebase-ads:17.1.2'
0
code4rox

In meinem Fall habe ich meine build.gradle-Datei durch diese Zeile ersetzt

implementation 'com.google.firebase:firebase-core:16.0.8'

mit

implementation 'com.google.firebase:firebase-core:15.0.0' 

und fügte diese Zeile hinzu

implementation 'com.google.Android.gms:play-services-location:15.0.0'

Jetzt ist es gut

0
Maddu Swaroop

geben Sie einfach den Code ein:

    implementation 'com.google.firebase:firebase-core:16.0.6'
    implementation 'com.google.firebase:firebase-database:16.0.6'

und wieder aufbauen. es funktioniert gut für mich

0
shahid

Ich stieß auf dieses Problem und bemerkte, dass die Versionshinweise erwähnt:

Firebase erfordert jetzt, dass die App-Gradle-Datei com.google.firebase: firebase-core explizit als Abhängigkeit aufführt, damit Firebase-Dienste wie erwartet funktionieren.

Durch firebase-core eine App-Abhängigkeit (sowie eine Bibliotheksabhängigkeit) wurde dieses Problem für mich gelöst.

0
Tad

Ich hatte einen Fehler The library com.google.Android.gms:play-services-measurement-base is being requested by various other libraries at [[16.0.2,16.0.2]], but resolves to 16.0.0. Disable the plugin and check your dependencies tree using ./gradlew :app:dependencies.

Das Ausführen von ./gradlew :app:dependencies zeigt, welche Abhängigkeiten falsche Abhängigkeiten erfordern (die in der eckigen Klammer). Für mich kam das Problem von Firebase-Core: 16.0.3, wie unten gezeigt. Ich habe es behoben, indem ich Firebase-Core auf 16.0.1 heruntergestuft habe

+--- com.google.firebase:firebase-core:16.0.3
|    +--- com.google.firebase:firebase-analytics:16.0.3
|    |    +--- com.google.Android.gms:play-services-basement:15.0.1
|    |    |    \--- com.Android.support:support-v4:26.1.0 (*)
|    |    +--- com.google.Android.gms:play-services-measurement-api:[16.0.1] -> 16.0.1
|    |    |    +--- com.google.Android.gms:play-services-ads-identifier:15.0.1
|    |    |    |    \--- com.google.Android.gms:play-services-basement:[15.0.1,16.0.0) -> 15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-basement:15.0.1 (*)
|    |    |    +--- com.google.Android.gms:play-services-measurement-base:[16.0.2] -> 16.0.2
0
Eric Kim

Wenn die Nachricht lautet:

Die Bibliothek com.google.Android.gms: play-services-Measurement-Base lautet von verschiedenen anderen Bibliotheken unter [[15.0.4,15.0.4]] angefordert, aber aufgelöst zu 15.0.2. Deaktivieren Sie das Plugin und überprüfen Sie Ihre Abhängigkeiten Baum mit ./gradlew: app: Abhängigkeiten.

Ändern Sie die Version aller verwendeten Play-Service-Bibliotheken in die Version, die Sie benötigen ( 15.0.2 in diesem Fall), um das Problem zu lösen. 

In meinem Fall habe ich geändert:

implementation 'com.google.Android.gms:play-services-base:+' -> implementation 'com.google.Android.gms:play-services-base:15.0.2'
implementation 'com.google.Android.gms:play-services-location:+' -> implementation 'com.google.Android.gms:play-services-location:15.0.2'
implementation 'com.google.Android.gms:play-services-maps:+' -> implementation 'com.google.Android.gms:play-services-maps:15.0.2'
implementation 'com.google.Android.gms:play-services-auth:+' -> implementation 'com.google.Android.gms:play-services-auth:15.0.2'
implementation 'com.google.Android.gms:play-services-places:+' -> implementation 'com.google.Android.gms:play-services-places:15.0.2'
0
Jose Q

Hier gelöst: Auch ich hatte das gleiche Problem, als ich versuchte, Crashlytics in Firebase hinzuzufügen. Aktualisieren Sie die neueste Version der Abhängigkeiten für com.google.Android.gms: play-services und com.google.firebase: ...... . Die Probleme werden automatisch gelöst

0
Priya Rajan

Ich habe die folgenden Abhängigkeiten in meinem Projekt geändert, damit es funktioniert.

build.gradle (App):

implementation 'com.google.firebase:firebase-core:16.0.1'

zu

implementation 'com.google.firebase:firebase-core:16.0.8'

build.gradle (App):

classpath 'com.google.gms:google-services:4.0.1'

zu

classpath 'com.google.gms:google-services:4.2.0'

**** Anmerkung:

Verwenden Sie den folgenden Link für die aktualisierte Verwendung von Bibliotheken mit Abhängigkeiten: https://firebase.google.com/docs/Android/setup

0
Ali Baba