it-swarm.com.de

Android_Install-Version ist fehlgeschlagen

Ich werde mein apk auf GooglePlay Store aktualisieren und ich weiß, dass ich den Versionscode und den Namen in der Manifestdatei aktualisieren muss, jedoch install_failed.

Installation error: INSTALL_FAILED_VERSION_DOWNGRADE 

Bitte überprüfen Sie die Logcat-Ausgabe auf weitere Details. Start abgebrochen!

Ich habe den Versionscode und den Namen folgendermaßen geändert: Android: versionCode = "2" Android: versionName = "1.0.5"

Habe ich es falsch gemacht?

13
user3503072

Deinstallieren Sie einfach die Anwendung auf Ihrem Gerät und installieren Sie dann die neue.

36
Martin

Bei der Installation über adb können Sie -d übergeben, um ein Downgrade der Version zu ermöglichen

adb install -d -r your.apk

-r wird auch die vorhandene App ersetzen

15
kemuri
Installation error: INSTALL_FAILED_VERSION_DOWNGRADE Please check logcat output for more details. Launch canceled!

Ich habe das Problem gelöst, indem Sie den Befehl Aufforderung zum Navigieren zum Projektordner> Adb-Deinstallationspaket (Sie können das Paket aus der Datei Manifest.xml erhalten).

In meinem Fall: D:\projectFolder\AndriodApp> adb deinstallieren Sie com.example.app

Starten Sie die App erneut im Emulator oder auf dem Mobilgerät.

8

benutze einfach folgendes:

$ adb -e uninstall your.application.package.name

5
Yanmin Lu

Anscheinend ist die versionCode Ihrer aktuell installierten Version der Anwendung größer als 2, was zu einer fehlgeschlagenen Installation auf dem Gerät führt.

3
keyboardsurfer

Dies geschieht, wenn Ihre installierte APK-Version kleiner ist als die Version, mit der Sie versuchen, APK zu erstellen. Zum Beispiel aktualisieren Sie einfach Ihre Version und versuchen, apk damit zu erstellen, aber Sie haben bereits ein installiertes apk auf Ihrem Gerät, das von der vorherigen Version erstellt wurde. 

In diesem Fall müssen Sie die vorherige apk deinstallieren und mit der vorhandenen Version eine neue erstellen. 

3
Yusuf

Ich habe es erst in der Einstellung> apps> allapps> app deaktiviert und konnte es mit dem regulären Befehl installieren: Adb -r name.apk

2
Jose Flores

Zuerst müssen Sie versionCode und versionName auf Palystore apk überprüfen und dann die Nummer für versionCode und versionName um eins erhöhen.

zum Beispiel: im Playstore versionCode="42"und versionName="1.4.2" und versionCode="43" und versionName="1.4.3" in Ihrem neuesten Code ändern

1
Ajay Takur

Ajay Thakur ist richtig. Der aktuelle Versionscode Ihrer App sollte größer als der Playstore-Code sein.

Aber beziehen Sie sich auf this , antworten Sie einmal. Es kann Ihr Problem lösen.

0
Atul Panda

In meinem Fall musste ich die Version auf dem Gerät entfernen und deinstallieren und dann das Projekt ausführen. Es installierte die Version in der IDE neu und funktionierte wie ein Zauber.

0
Krishna Vedula

Ein anderes Beispiel für dieselbe Fehlermeldung: In Android Studio (im Gegensatz zu Eclipse) werden der Versionscode/-name in der Gradel-Datei aufgeführt. Wenn sie sowohl dort als auch im Manifest anwesend sind, haben die Absolventen Vorrang.

0
Seva Alekseyev