it-swarm.com.de

Android CI-Build: aapt2-proto.jar konnte nicht gefunden werden

Ich habe einen Fehler beim Build auf einem Bitbucket-CI-Server:

> Could not resolve all artifacts for configuration ':classpath'.
   > Could not find aapt2-proto.jar (com.Android.tools.build:aapt2-proto:0.3.1).
     Searched in the following locations:
         https://jcenter.bintray.com/com/Android/tools/build/aapt2-proto/0.3.1/aapt2-proto-0.3.1.jar

Ich habe ähnliche Fragen gesucht, aus denen hervorgeht, dass das Google Maven-Repository fehlt. Build-Datei der obersten Ebene:

buildscript {

    repositories {
        jcenter()
        google()
    }
    dependencies {
        classpath 'com.Android.tools.build:gradle:3.2.1'
        classpath 'com.neenbedankt.gradle.plugins:Android-apt:1.8'
        classpath 'com.jakewharton:butterknife-gradle-plugin:8.8.0'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin"
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven { url "https://jitpack.io" }
    }
}

Und meine Build-Datei auf App-Ebene:

buildscript {
    repositories {
        maven { url 'https://maven.fabric.io/public' }
        google()
    }

    dependencies {
        classpath 'io.fabric.tools:gradle:1.26.1'
    }
}
apply plugin: 'com.Android.application'
apply plugin: 'kotlin-Android'
apply plugin: 'io.fabric'

repositories {
    maven { url 'https://maven.fabric.io/public' }
    google()
    mavenCentral()
}
49
estn

Verschieben Sie die google()-Methode an den Anfang des Ausführungsblocks. 

Möglicherweise ist es die Reihenfolge der Repositorys, die darin durchsucht werden, die das Problem verursacht.

Ändern Sie dies beispielsweise:

repositories {
  maven { url 'https://maven.fabric.io/public' }
  google() // from here
  mavenCentral()
}

Zu diesem:

repositories {
  google() // to here
  maven { url 'https://maven.fabric.io/public' }
  mavenCentral()
}

Wenn das nicht hilft, anstatt die google()-Methode aufzurufen, ändern Sie sie wie folgt:

maven {
  url 'https://maven.google.com/'
  name 'Google'
}

UPDATE

Wenn alle oben genannten Punkte nicht geholfen haben, stellen Sie sicher, dass Ihre gradle-Version mindestens 3.0.0 ist:

dependencies {
  classpath 'com.Android.tools.build:gradle:3.2.1'
}

Und die gradle-wrapper-Version ist mindestens 4.1:

Normalerweise hier gelegen: project_name/gradle/wrapper/gradle-wrapper.properties

distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-all.Zip

Quelle

68
HedeH

Ein Upgrade des Gradle-Wrappers (in gradle-wrapper.properties) auf gradle-4.10.2-all.Zip hat das Problem für mich behoben. 

22

Aktualisieren Sie die Gradle-Version

Über die Android-Version Release-Seite können Sie die kompatible Version Ihres Gradle-Plugins überprüfen. 

Aktualisierungsversion in gradle-wrapper.properties in yourProject/gradle/wrapper aktualisieren

distributionUrl=https\://services.gradle.org/distributions/gradle-4.4.0-all.Zip
Plugin version  Required Gradle version

   2.3.0+             3.3+
   3.0.0+             4.1+
   3.1.0+             4.4+

Beachten Sie, dass die Reihenfolge wichtig ist. google() sollte das oberste Plugin-Repo sein.

Für Android Studio Version> 3.0

buildscript {
  repositories {
      google() // move it to top
      jcenter()
  }
  dependencies {
      classpath 'com.Android.tools.build:gradle:3.2.1' // your Android Studio Version
  }
} 
allprojects {
  repositories {
      google() // move it to top
      jcenter()
}

google() plugin wird seit Android Studio Version 3.0 oder höher benötigt.

Für Android Studio-Version <3.0

buildscript {
  repositories {
      maven {
       url 'https://maven.google.com/'
       name 'Google'
      }
      jcenter()
  }
  dependencies {
      classpath 'com.Android.tools.build:gradle:2.3.0' // your Android Studio Version
  }
} 
allprojects {
  repositories {
      maven {
       url 'https://maven.google.com/'
       name 'Google'
      }
      jcenter()
}
0
Khemraj