it-swarm.com.de

Welche Version von jQuery verwendet Drupal 8)?

Wie kann ich herausfinden, welche Version von jQuery eine bestimmte Version von Drupal 8 Core verwendet)?

6

Wenn Sie etwas Zeit sparen möchten, können Sie in der Javascript-Konsole jQuery.fn.jquery Eingeben, die auf jeder Site mit jQuery funktioniert, nicht nur Drupal Sites).

Im Moment Drupal 8 Core verwendet jQuery 2.1.4, aber es sieht so aus, als ob jQuery 3 in Drupal 8.4.x) implementiert wurde.

https://www.drupal.org/node/2533498

8

Dies ist wahrscheinlich nicht die beste Frage, da sich die Antwort im Laufe der Zeit basierend auf der spezifischen Version von Drupal ändern kann.

Der genaueste Weg, um herauszufinden, welche Version einer JavaScript-Bibliothek von Drupal core) verwendet wird, besteht darin, direkt in der core/core.libraries.yml - Datei nach einer bestimmten Version von Drupal zu suchen. Eine der einfachsten Um dies zu tun, durchsuchen Sie das Git-Repository von Drupal online:

http://cgit.drupalcode.org/drupal/tree/core/core.libraries.yml#n334

jquery:
  remote: https://github.com/jquery/jquery
  version: VERSION_HERE
  license:
    name: MIT
    url: https://github.com/jquery/jquery/blob/VERSION_HERE/MIT-LICENSE.txt
    gpl-compatible: true
  js:
    assets/vendor/jquery/jquery.min.js: { minified: true, weight: -20 }

Für Drupal 6-7, ohne installiertes jquery_update-Modul, kann die Version von Drupal am einfachsten gefunden werden, indem Sie in das Verzeichnis misc/ Gehen). und schauen Sie oben in die Datei jquery.js. Dies ist v1.2.6 bzw. v1.4.4.

Für Drupal 5) ist die Version von jquery nicht ohne weiteres ersichtlich, aber das praktische git blame misc/jquery.js Zeigt das Commit d57bae aktualisiertes jQuery auf v1.0.4.

8
mradcliffe