it-swarm.com.de

Drush dl funktioniert nicht mit PHP 7 und Ubuntu 16.04

Wenn ich versuche zu tun:

drush dl drupal-8

ich bekomme folgenden Fehler:

PHP Fatal error:  Uncaught Error: Call to undefined function Drush\UpdateService\simplexml_load_file() in /home/alexander/.config/composer/vendor/drush/drush/lib/Drush/UpdateService/Project.php:74
Stack trace:
#0 /home/alexander/.config/composer/vendor/drush/drush/lib/Drush/UpdateService/ReleaseInfo.php(64): Drush\UpdateService\Project::getInstance(Array, 86400)
#1 /home/alexander/.config/composer/vendor/drush/drush/lib/Drush/UpdateService/ReleaseInfo.php(122): Drush\UpdateService\ReleaseInfo->get(Array)
#2 /home/alexander/.config/composer/vendor/drush/drush/commands/pm/download.pm.inc(111): Drush\UpdateService\ReleaseInfo->selectReleaseBasedOnStrategy(Array, '', 'auto', false, NULL)
#3 /home/alexander/.config/composer/vendor/drush/drush/includes/command.inc(366): drush_pm_download()
#4 /home/alexander/.config/composer/vendor/drush/drush/includes/command.inc(217): _drush_invoke_hooks(Array, Array)
#5 /home/alexander/.config/composer/vendor/drush/drush/includes/command.inc(185): drush_command()
#6 /home/alexander/.config/compos in /home/alexander/.config/composer/vendor/drush/drush/lib/Drush/UpdateService/Project.php on line 74
Drush command terminated abnormally due to an unrecoverable error.

Andere Befehle funktionieren: drush cc, drush status.

Hier ist die Ausgabe des Drush-Status:

 PHP executable         :  /usr/bin/php
 PHP configuration      :  /etc/php/7.0/cli/php.ini
 PHP OS                 :  Linux
 Drush script           :  /home/alexander/.config/composer/vendor/drush/drush/drush.php
 Drush version          :  8.1.2
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :
11
Alexander Kim

Klingt so, als hätten Sie es geschafft, PHP ohne die Erweiterung simplexml) zu installieren/konfigurieren.

Installieren Sie das php7.0-xml-Paket mit apt-get wie folgt.

Sudo apt-get install php-xml

Überprüfen Sie auch das UI-Installationsprogramm. Wenn Sie dies vermissen, fehlen Ihnen wahrscheinlich auch einige andere Erweiterungen, die mbstring, Gd usw. verknüpfen, um Drupal zu installieren/verwenden.

17
Berdir