it-swarm.com.de

Das Bildfeld wird in der Ansicht / im Block nicht angezeigt

Ich verwende derzeit Drupal 7) und versuche, meine Bilder in einer Ansicht auf der Hauptseite anzuzeigen. Bisher habe ich Folgendes erstellt:

  • Erstellt einen Inhaltstyp mit einem Titel, einem Text und einem Bildfeld
  • Es wurden zwei Knoten erstellt, die beide ein hochgeladenes Bild enthalten
  • Eine Ansicht und ein Block mit
    • felder: Titel, NID und Bild
    • gefiltert nach: veröffentlicht und Typ (auf den von mir erstellten Inhaltstyp eingestellt)

Wenn ich mir meinen Inhaltstyp ansehe, sehe ich den Namen, den Text und das Bild, das ich hochgeladen habe. Wenn ich zur Hauptseite gehe, kann ich meine Ansicht mit dem Inhalt sehen, aber es werden nur der Name und der Text angezeigt. Das Bild wird nicht angezeigt.

Kann ich irgendetwas herunterladen und/oder tun, damit dies funktioniert? Ich möchte nur, dass die Bilder innerhalb des Blocks angezeigt werden (aus meiner Sicht).

5
Kyra

überprüfen Sie die Seite admin/user/permissions. Wenn Sie den Imagecache verwenden, überprüfen Sie die Berechtigung zum Anzeigen des Imagecaches und legen Sie sie fest. und setzen Sie die Berechtigung für das Ansichtsfeld.

2
user780

@ Kyra, ich habe genau das gleiche Problem mit dem Bildfeld, das nicht in der Ansicht angezeigt wird, und dies würde ich sagen, da ich das Ansichtsmodul aktualisiert habe. Die Sache ist, ich benutze Drupal Commerce (mit Drupal Core 7), aber ich glaube nicht, dass das Problem direkt damit zusammenhängt: Ich habe eine Ansicht auf die Titelseite, Produkte anzeigen.

Im Bereich "Format":

  • Format: Raster | die Einstellungen
  • Anzeigen: Felder | die Einstellungen

Im Bereich "Felder":

  • Inhalt: Titel
  • Inhalt: Körper
  • Feld: Abbildung

In den "Filter" -Kriterien:

  • Inhalt: Veröffentlicht (Ja)
  • Inhalt: Klebrig (Ja).

In der Ansicht werden nur der Titel und der Text angezeigt. Wenn ich mir die Inhaltstypen außerhalb der Ansicht ansehe, wird natürlich deren Bild angezeigt. Dies tritt für alle Inhaltstypen und Produkte auf, die vor der Aktualisierung des Ansichtsmoduls erstellt wurden. Wenn Sie dort einen neuen Produkttyp, ein neues Produkt, eine neue Produktanzeige und schließlich einen Inhalt (der dem gerade erstellten Produkt gewidmet ist) erstellen, wird das Bild in der Ansicht angezeigt. Es scheint also, dass einige Einschränkungen in einigen Tabellen durcheinander gebracht wurden. Haben Sie es geschafft, dieses Problem zu lösen, Kyra?

1
carlino

Überprüfen Sie zum späteren Nachschlagen die Registerkarte Inhaltstyp "Anzeige verwalten". Es gibt eine Unterregisterkarte für "Inhalt" und "Teaser", daher müssen Sie sicherstellen, dass das Bildfeld dort angezeigt (und nicht ausgeblendet) wird. Sie können auch das Format usw. ändern.

0
Teknotica