it-swarm.com.de

Wie installiere ich das Google-Talkplugin?

Wie installiere ich das Google Talk-Plugin, damit ich gtalk und Google Plus verwenden kann?

37
yuttadhammo

Ab Ubuntu 11.10 wird multi-Arch für Anwendungen verwendet, die zuvor ia32-libs verwendet haben.

gtalk und Google Plus sind das gleiche Plugin. Sie bestehen aus einem 64-Bit-Plugin und einem 32-Bit-Daemon - und verwenden die veralteten ia32-libs. Es liegt an Google, ihr Paket irgendwann zu aktualisieren.

Unter Ubuntu 11.10 sollten AMD64-Benutzer weiterhin die 64-Bit-.deb-Datei verwenden, die unter http://www.google.com/chat/video auf AMD64-Systemen verfügbar ist, da die 32-Bit-.deb-Datei nicht verfügbar ist wird zu diesem Zeitpunkt ohne weitere Änderungen am System verwendet.

Nach dem Herunterladen kann das Plugin folgendermaßen installiert werden:

  1. Klicken Sie im Browser auf Öffnen.
  2. Öffnen Sie den Dateimanager, navigieren Sie zu ~/Downloads und doppelklicken Sie auf die Google Plugin Deb-Datei.

Bei beiden Methoden wird das Software Center geöffnet, um die Installation abzuschließen. Wenn Sie einen Abhängigkeitsfehler erhalten, stellen Sie sicher, dass Sie Universe in Ihren Softwarequellen ausgewählt haben.

19
pgraner

Hier ist ein hackiger Weg, um damit umzugehen:

  1. Laden Sie die 64-Bit-.deb-Datei von folgender Adresse herunter: http://www.google.com/tools/dlpage/res/talkvideo/hangouts/
  2. Erstellen Sie ein tmp-Verzeichnis:

    mkdir tmp
    
  3. Extrahieren Sie den Inhalt der .deb in das tmp-Verzeichnis:

    dpkg-deb -x google-talkplugin_current_AMD64.deb tmp
    
  4. Extrahieren Sie die Steuerdateien:

    dpkg-deb --control google-talkplugin_current_AMD64.deb tmp/DEBIAN
    
  5. Korrigieren Sie die Abhängigkeit:

    sed -i "s/lib32v4l-0/libv4l-0/" tmp/DEBIAN/control
    
  6. Packen Sie die .deb neu:

    dpkg -b tmp google-talkplugin_current_AMD64-fixed.deb
    
  7. Installieren Sie die feste Version:

    Sudo dpkg -i google-talkplugin_current_AMD64-fixed.deb
    
  8. Rufen Sie Google auf, um die .deb-Datei für 64-Bit-Oneiric zu reparieren: http://www.google.com/intl/en/+/learnmore/forum/

9
James Ward

Für Ubuntu 14 - es scheint einen Fehler im Software-Center zu geben, daher müssen Sie die Datei von Google-Servern herunterladen:

https://www.google.com/tools/dlpage/hangoutplugin

verwenden Sie dann die Befehlszeile, um die DEB-Datei zu installieren. Zum Download-Ordner navigieren:

cd ~/Downloads/

Installieren Sie die .deb-Datei über die Befehlszeile:

Sudo dpkg -i <google-talk-file.deb>
3
Joshua Kissoon

Installieren Sie vom offiziellen Google Repo aus, indem Sie diese Anweisungen :

Sudo sh -c 'echo "deb http://dl.google.com/linux/talkplugin/deb/ stable main" >> /etc/apt/sources.list.d/google-talkplugin.list'
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | Sudo apt-key add -
Sudo apt-get update
Sudo apt-get install google-talkplugin
0
Cerin