it-swarm.com.de

Installieren Sie Powershell in Ubuntu 17.04

Ich versuche, Powershell in Ubuntu 17.04 wie folgt zu installieren:

curl https://packages.Microsoft.com/keys/Microsoft.asc | Sudo apt-key add -

curl https://packages.Microsoft.com/config/ubuntu/16.04/prod.list | Sudo tee /etc/apt/sources.list.d/Microsoft.list

Sudo apt-get update

Sudo apt-get install -y powershell

Ich weiß, dass ich 16.04-Pakete verwende, die für die Installation erstellt wurden. Leider konnte ich die 17.04 nicht finden.

Und hier ist, welchen Fehler ich bei Sudo apt-get install -y powershell habe

The following packages have unmet dependencies:  
  powershell : Depends: libicu55 but it is not installable 

Dann habe ich versucht:

apt-cache search libicu

Ich konnte auch die zu installierende libicu55 nicht finden. Gibt es eine Möglichkeit, Powershell in Ubuntu 17.04 zu installieren?

11
Ender

Laden Sie die AppImage Version herunter und folgen Sie den Anweisungen :

Laden Sie unter Verwendung einer aktuellen Linux-Distribution AppImage PowerShell-6.0.0-alpha.18-x86_64.AppImage von der Release-Seite auf den Linux-Computer herunter.

Führen Sie dann im Terminal Folgendes aus:

chmod a+x PowerShell-6.0.0-beta.5-x86_64.AppImage
./PowerShell-6.0.0-beta.5-x86_64.AppImage

Mit AppImage können Sie PowerShell ausführen, ohne es zu installieren. Es ist eine tragbare Anwendung, die PowerShell und seine Abhängigkeiten (einschließlich der Systemabhängigkeiten von .NET Core) in einem zusammenhängenden Paket zusammenfasst. Dieses Paket funktioniert unabhängig von der Linux-Distribution des Benutzers und ist eine einzelne Binärdatei.

9
user2856

Laden Sie das libicu55 -Paket von http://packages.ubuntu.com/en/xenial/AMD64/libicu55/download herunter

wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu55_55.1-7ubuntu0.4_AMD64.deb
Sudo apt install ./libicu55_55.1-7ubuntu0.4_AMD64.deb

Folgen Sie dann Anweisungen für 16.04

...
Sudo apt install -y powershell

Quelle: https://asknicks.blogspot.ru/2017/05/install-powershell-on-ubuntu-17.html

9
Adobe

Microsoft hat noch keine Pakete für 17.04. Schau dir ihren Github an :

enter image description here

Das Problem, das Sie haben, ist, dass ihr Paket von libicu55 abhängt, aber 17.04 hat dieses Paket nicht in seinen Repositories . Solange Sie nicht von der Quelle erstellen , können Sie die öffentlichen Powershell-Pakete nicht installieren.

2
Foxie

Besuchen Sie die offizielle Microsoft PowerShell-Dokumentation Webseite und klicken Sie auf den Link, um PowerShell auf GitHub zu besuchen, oder besuchen Sie sie direkt. Dort finden Sie Links zum Herunterladen von PowerShell .deb-Dateien für Ubuntu 14.04, 16.04 und 17.04.

Laden Sie die PowerShell-DEB-Datei herunter und doppelklicken Sie darauf, um sie in der Softwareanwendung zu öffnen.


IMG:  Ubuntu 14.04 und höher

PowerShell kann als Snap-Paket in allen derzeit unterstützten Versionen von Ubuntu installiert werden. Um das PowerShell Core-Snap-Paket zu installieren, öffnen Sie das Terminal und geben Sie Folgendes ein:

Sudo snap install powershell --classic  
0
karel