it-swarm.com.de

XPRA-Version auf Ubuntu 16.04

Wenn ich meinen Computer auf Ubuntu 16.04 aktualisiert habe, wurde das Paket xpra auf Version 0.15.8 aktualisiert.

Ich habe einige Kompatibilitätsprobleme mit dieser Version. Ich habe gelesen, dass v0.15.x eine nicht unterstützte Version ist und v0.14.x die aktuelle LTS-Version (Long Term Support) ist ( https://www.xpra.org/trac/wiki/Versions ).

Wie kann ich xpra V0.14.x unter Ubuntu 16.04 installieren?

4
Mikel Antoñana

Das Aktualisieren auf 0.14.x erlaubte mir immer noch nicht, xpra zu starten, das Aktualisieren auf den neuesten Zweig 2.0.x jedoch.

TL; DR kopiert von meinem Blog :

# Administrator privileges
Sudo su -

# Import the packager's key:
apt-get install curl
curl http://winswitch.org/gpg.asc | apt-key add -

# Xenial Xerus (16.04)
echo "deb http://winswitch.org/ xenial main" > /etc/apt/sources.list.d/winswitch.list;
apt-get install software-properties-common >& /dev/null;
add-apt-repository universe >& /dev/null;
apt-get update;
apt-get install winswitch
6
brtknr

Öffnen Sie das Terminal und geben Sie Folgendes ein:

cd Desktop/
wget -c http://xpra.org/dists/xenial/main/binary-AMD64/xpra_0.14.35-1_AMD64.deb # official deb package from xpra.org
Sudo dpkg -i xpra_0.14.35-1_AMD64.deb  

xpra v0.14.x ist die aktuelle LTS-Version (Long Term Support) und xpra_0.14.35-1_AMD64.deb ist mit Ubuntu 16.04 kompatibel.

Wenn Sie beim Aktualisieren der Software eine Meldung über fehlerhafte Pakete erhalten, entfernen Sie xpra mit dem folgenden Befehl:

Sudo dpkg -r xpra  

Wenn beim Aktualisieren der Software immer noch die Meldung "Pakete kaputt" angezeigt wird, war dies nicht die Schuld von xpra. Sie müssen zuerst die Fehlermeldung "Fehlerhafte Pakete" beheben, bevor Sie xpra installieren. Dies sollte jedoch als separate Frage gestellt werden.

0
karel