it-swarm.com.de

Winehq-staging, Ubuntu 16.04 64bit kann nicht installiert werden

Ich habe Wine auf Ubuntu 16.04 ausgeführt, das über Sudo apt-get install wine installiert wurde, aber ich möchte auf Wine-Staging umsteigen. Ich versuche, den Anweisungen unter https://wiki.winehq.org/Ubunt zu folgen

Ich habe zuerst wine deinstalliert und sichergestellt, dass alle Pakete auf dem neuesten Stand sind:

Sudo apt-get remove wine wine-mono wine-gecko winetricks
Sudo apt-get autoremove
Sudo apt-get update
Sudo apt-get upgrade

Ich habe dann neu gestartet und die folgenden Befehlsfolgen ausgeführt:

Sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/Release.key
Sudo apt-key add Release.key
Sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
Sudo apt-get update

Der Befehl zum Installieren von winehq-staging schlägt jedoch fehl, da die Abhängigkeit von der Weinbereitstellung nicht erfüllt ist:

Sudo apt-get install --install-recommends winehq-staging

The following packages have unmet dependencies:
 winehq-staging : Depends: wine-staging (= 2.13.0~xenial)
E: Unable to correct problems, you have held broken packages.

Die Installation von wine-staging schlägt fehl, da die Abhängigkeit von wine-staging-i386 nicht erfüllt ist:

Sudo apt-get install wine-staging

The following packages have unmet dependencies:
 wine-staging : Depends: wine-staging-i386 (= 2.13.0~xenial)
E: Unable to correct problems, you have held broken packages.

Die Installation von wine-staging-i386 schlägt mit verschiedenen nicht erfüllten Abhängigkeiten von -i386 Paketen fehl. Einige davon anzeigen (die Liste ist viel länger):

Sudo apt-get install wine-staging-i386

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libasound2:i386 (>= 1.0.16) but it is not installable
                          Depends: libglib2.0-0:i386 (>= 2.12.0) but it is not installable
                          Depends: libgphoto2-6:i386 (>= 2.5.9) but it is not installable
                          Depends: libgphoto2-port12:i386 (>= 2.5.9) but it is not installable

(snip)

                          Recommends: libxslt1.1:i386 (>= 1.1.25) but it is not installable
                          Recommends: libxxf86vm1:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

Wenn ich versuche, das erste zu installieren, ist es nicht verfügbar:

Sudo apt-get install libasound2:i386

Package libasound2:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libasound2-data

E: Package 'libasound2:i386' has no installation candidate

Das Paket libasound2-data ist jedoch bereits installiert und die neueste Version.

Ich bin nicht sicher, was ich als nächstes versuchen soll.

2
Paul Lamb

dies ist eine Ergänzung zur Antwort von Elber CM

vor der Ausführung von "$ Sudo apt-get install --install-recommends winehq-staging" musste ich die folgenden Bibliotheken installieren:

$ Sudo apt-get install libasound2-plugins:i386
$ Sudo apt-get install wine-staging-i386
$ Sudo apt-get install wine-staging

und schlussendlich

$ Sudo apt-get install --install-recommends winehq-staging

voila, jetzt klappt es.

3
trodevel

Englisch ist nicht meine Muttersprache, bitte haben Sie etwas Geduld.

Anscheinend ist die Lösung etwas komplexer. Das folgende Tutorial behandelt Folgendes:

https://codereviewvideos.com/blog/wine-1-9-11-on-ubuntu-16-04/

Es ist notwendig, zuerst einige Bibliotheken zu installieren:

Sudo apt-get install gcc-multilib libasound2-dev:i386 libgsm1-dev:i386 libjpeg8-dev:i386 liblcms2-dev:i386 libldap2-dev:i386 libmpg123-dev:i386 libopenal-dev:i386 libv4l-dev:i386 libx11-dev:i386 libxinerama-dev:i386 libxml2-dev:i386 zlib1g-dev:i386

Dann mach nochmal ein Update:

Sudo apt-get update

Wieder einige fehlende Bibliotheken:

Sudo apt-get install libcapi20-dev:i386 libcups2:i386 libdbus-1-3:i386 libfontconfig:i386 libfreetype6:i386 libglu1-mesa:i386 libgphoto2-6:i386 libncurses5:i386 libosmesa6:i386 libsane:i386 libxcomposite1:i386 libxcursor1:i386 libxi6:i386 libxrandr2:i386 libxslt1.1:i386 ocl-icd-libopencl1:i386 libgd3:i386

Führen Sie zum Schluss die Installation durch:

Stabiler Zweig

Sudo apt-get install --install-recommends winehq-stable

Entwicklungszweig

Sudo apt-get install --install-recommends winehq-devel

Staging-Zweig

Sudo apt-get install --install-recommends winehq-staging

PSDT: Einige der Librares könnten enthalten sein, dies hängt von anderen Programmen ab, die sie verwenden könnten, und von der Ubuntu-Version.

1
Elber CM

Das Problem wurde behoben, indem alle Kontrollkästchen in "Software und Updates" markiert wurden. Danach konnte ich alle Abhängigkeiten und Weinbereitstellungen erfolgreich installieren über:

Sudo apt-get update
Sudo apt-get upgrade
Sudo apt-get install --install-recommends winehq-staging
1
Paul Lamb