it-swarm.com.de

Wie installiere ich Pakete, wenn Abhängigkeit bereits von PPA installiert ist?

Ich versuche libgdal-dev zu installieren:

Sudo apt-get install libgdal-dev

Aber es hat unerfüllte Abhängigkeiten: Depends: libpng-dev

Welche selbst kann nicht installiert werden, weil:

libpng12-dev : Depends: libpng12-0 (= 1.2.54-1ubuntu1.1) but 1.2.54-5x0~ppa is to be installed

Dieses Paket wird von einem ppa installiert:

dpkg -s libpng12-0 | grep ^Maintainer
Maintainer: Otto Meier <[email protected]>

( via )

Ich möchte das ppa beibehalten, da es GIMP 2.9 bereitstellt.


Frage :

  • Wie kann ich libpng12-dev und libgdal-dev installieren (möglicherweise bestimmte Abhängigkeiten ignorieren oder manuell ändern)?

  • oder allgemein: Wie installiere ich Pakete, wenn Dependency bereits in einer anderen Version von PPA installiert ist?


(Hinweis: Die Installation von GIMP mit Snap ist weder bevorzugt noch möglich )



Was ich versucht habe:

Ich habe libpng12-dev installiert und ignoriere libpng12-0 dependecy ( via ):

apt download libpng12-dev
Sudo dpkg --ignore-depends=libpng12-0 -i libpng12-dev_1.2.54-1ubuntu1.1_AMD64.deb

Das hat funktioniert.
Außerdem hatte libgdal-dev immer noch unmnet-Abhängigkeiten, also habe ich dasselbe getan:

Sudo apt install libgdal-dev
Sudo dpkg --ignore-depends=libpng12-0 -i libgdal-dev_2.2.2+dfsg-1~xenial1_AMD64.deb #png12-dev_1.2.54-1ubuntu1.1_AMD64.deb

dpkg: dependency problems prevent configuration of libgdal-dev:
 libgdal-dev depends on libarmadillo-dev; however:
  Package libarmadillo-dev is not installed.
 libgdal-dev depends on libcurl4-gnutls-dev | libcurl-ssl-dev; however:
  Package libcurl4-gnutls-dev is not installed.
  Package libcurl-ssl-dev is not installed.
 libgdal-dev depends on libdap-dev; however:
  Package libdap-dev is not installed.
 libgdal-dev depends on libepsilon-dev; however:
  Package libepsilon-dev is not installed.
 libgdal-dev depends on libfreexl-dev; however:
  Package libfreexl-dev is not installed.
 libgdal-dev depends on libfyba-dev; however:
  Package libfyba-dev is not installed.
 libgdal-dev depends on libgeos-dev; however:
  Package libgeos-dev is not installed.
 libgdal-dev depends on libgeotiff-dev; however:
  Package libgeotiff-dev is not installed.
 libgdal-dev depends on libgif-dev; however:
  Package libgif-dev is not installed.
 libgdal-dev depends on libhdf4-alt-dev; however:
  Package libhdf4-alt-dev is not installed

Also habe ich hier angehalten und die Situation wieder behoben:

Sudo dpkg -r libgdal-dev
Sudo dpkg -r libpng12-dev
3
pLumo

@ dsstorefile1 gab den richtigen Hinweis, um mein Problem zu beheben:

Das in der Frage was verlinkte ppa wurde für 16.04 erstellt, als ich es installierte, aber es wurde geändert und der Betreuer entfernte die meisten Pakete für xenial, einschließlich libpng12-0.


So habe ich die Situation behoben:

  • Entferne den ppa mit ppa-purge:

    Sudo ppa-purge ppa:otto-kesselgulasch/gimp
    
  • Downgrade das libpng12-0 -Paket auf die Version von den offiziellen Repos:

    Sudo apt install libpng12-0=1.2.54-1ubuntu1.1
    
  • Installieren Sie libgdal-dev:

    Sudo apt install libgdal-dev
    

Mir ist auch aufgefallen, dass folgende Pakete auch Reste von diesem ppa sind:

libbabl-0.1-0
libgegl-0.3-0
liblcms2
libwebp6

Also habe ich auch diese herabgestuft/entfernt:

Sudo apt install libbabl-0.1-0=0.1.16-1
Sudo apt install libgegl-0.3-0=0.3.4-1ubuntu2
Sudo apt install liblcms2-2=2.6-3ubuntu2
Sudo apt remove libwebp6 #no candidate from repos
2
pLumo