it-swarm.com.de

Wie installiere ich libqt4-core und libqt4-gui auf Ubuntu 16.04 LTS?

Ich habe ein Upgrade auf Ubuntu 16.04 LTS durchgeführt. Es fehlen jedoch die Pakete libqt4-core und libqt4-gui.

Wie könnte ich sie am 16.04 installieren?

Vielen Dank.

15
Enze Chi

Diese Pakete libqt4-core und libqt4-gui gibt es ab Ubuntu 16.04 LTS nicht mehr. Es waren Dummy-Pakete mit Abhängigkeiten zu anderen Paketen. Mit dem folgenden Verfahren wird das Vidyo-Paket so geändert, dass Arbeitsabhängigkeiten verwendet werden.

  1. Stellen Sie zunächst sicher, dass alle erforderlichen libqt4-Pakete installiert sind, die nicht standardmäßig installiert sind:

    Sudo apt install libqt4-designer libqt4-opengl libqt4-svg libqtgui4 libqtwebkit4
    
  2. Erstellen Sie ein Skript, um die im Paket definierte Abhängigkeit zu ändern. Verwenden Sie das mitgelieferte Skript videbcontrolhier .

  3. Führen Sie das Skript videbcontrol VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.deb aus, das die Abhängigkeiten in einem vi-Editor öffnet

  4. Ersetzen Sie Depends: libxss1,libaudio2,libasound2,libqt4-gui (>= 4.8.1), libqt4-network durch Depends: libxss1,libaudio2,libasound2,libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4,libqt4-network. Dadurch wird eine Datei mit dem Namen VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.modified.deb erstellt, die die neue Abhängigkeit enthält.

    Wenn Sie vi nicht kennen, sehen Sie die Paketinformationen

    1. bewegen Sie den Cursor mit den Pfeilen nach unten zu der Zeile, die mit Depends: beginnt.
    2. geben Sie den Buchstaben i ein, um in den Einfügemodus zu gelangen
    3. kopieren Sie die neue Zeile mit der rechten Maustaste und geben Sie return ein
    4. geben Sie escape ein, um den Einfügemodus zu verlassen
    5. geben Sie dd ein, um die alte Depends Zeile zu löschen
    6. geben Sie ZZ ein, um die Änderung zu speichern und zu beenden (zwei Großbuchstaben z).
  5. Installieren Sie das Vidyo-Paket, indem Sie den folgenden Befehl ausführen:

    Sudo apt install VidyoDesktopInstaller-ubuntu64-TAG_VD_3_6_3_017.modified.deb
    

Genießen

10
chmike

Dank https://ubuntuforums.org/showthread.php?t=110458 und @chmike Diese Abhängigkeiten haben bereits höhere Versionen, wie ich fand. Es ist in Ordnung, stattdessen die DEB-Datei zu ändern. @ bean1975 hat eine kürzere Methode:

dpkg-deb -x yourfile.deb newdir 
dpkg-deb --control yourfile.deb newdir/DEBIAN
gedit newdir/DEBIAN/control

und ändere die libqt4-gui (>= 4.8.1) mit libqt4-designer,libqt4-opengl,libqt4-svg,libqtgui4,libqtwebkit4

dpkg -b newdir modified.deb

und du kannst es jetzt benutzen !!!

3
Amartya Rej

Versuchen Sie dies, wie es bei mir funktioniert hat:

Sudo apt-get -f install

Dies wurde von Terminal selbst vorgeschlagen und es hat etwas Magie und was nicht.

0
user644585

Ich fand diese Anweisungen von der Vidyo-Website am einfachsten zu befolgen. Sie haben bei einigen Upgrades konsequent gearbeitet.

0
SteveSong