it-swarm.com.de

Wie installiere ich die fehlende Shared Library libQtWebKit.so.4?

Weiß jemand, wo ich diese Bibliothek bekommen kann: libQtWebKit.so.4

Beim Start von Clipgrab wird folgende Fehlermeldung angezeigt:

$ /home/pst007x/Applications/ClipGrab/clipgrab-3.6.1
/home/pst007x/Applications/ClipGrab/clipgrab-3.6.1: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory

Ubuntu 16.04 LTS 64bit

6
pst007x

Sie erhalten es, indem Sie libqtwebkit4 installieren:

Sudo apt install libqtwebkit4

Um herauszufinden, welches Paket eine bestimmte Datei enthält, können Sie apt-file verwenden (installieren Sie sie, indem Sie Sudo apt install apt-file ausführen). Für den Fall von libQtWebKit.so.4:

$ apt-file search libQtWebKit.so.4
libqtwebkit4: /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
libqtwebkit4: /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4.10
libqtwebkit4: /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4.10.2

Wenn Sie es vorziehen, einen Webbrowser zu verwenden, gehen Sie zu http://packages.ubuntu.com , suchen Sie unter "Durchsuchen des Inhalts von Paketen" nach libQtWebKit.so.4, und Sie erhalten:

File                                            Packages
/usr/lib/aarch64-linux-gnu/libQtWebKit.so.4     libqtwebkit4 [arm64]
/usr/lib/arm-linux-gnueabihf/libQtWebKit.so.4   libqtwebkit4 [armhf]
/usr/lib/i386-linux-gnu/libQtWebKit.so.4        libqtwebkit4 [i386]
/usr/lib/powerpc-linux-gnu/libQtWebKit.so.4     libqtwebkit4 [powerpc]
/usr/lib/powerpc64le-linux-gnu/libQtWebKit.so.4 libqtwebkit4 [ppc64el]
/usr/lib/s390x-linux-gnu/libQtWebKit.so.4       libqtwebkit4 [s390x]
/usr/lib/x86_64-linux-gnu/libQtWebKit.so.4      libqtwebkit4 [AMD64]
14
edwinksl