it-swarm.com.de

WARNUNG: amdgpu dkms konnte den Kernel nicht ausführen (sowohl am 16.04 als auch am 18.04)

Seit den letzten 4 Tagen versuche ich, amdgpu pro-Treiber auf meinem Ubuntu-System zu installieren, und es wird eine Fehlermeldung angezeigt.

  1. Ich habe Treiber von hier für Rx580 heruntergeladen.

  2. Ich folge den Installationsanweisungen von hier .

  3. Bei der erstmaligen Installation wird der Befehl dkms nicht gefunden.

enter image description here

  1. das Ausführen des folgenden Befehls zeigt mir, dass ich dkms installieren soll

    dkms status

  2. Installieren von dkms mit dem folgenden Befehl

    Sudo apt-get install dkms

  3. Versuchen Sie dann, mit dem folgenden Befehl zu installieren, und der folgende Fehler ist der Screenshot für denselben.

    ./amdgpu-pro-install -y

enter image description here

  1. Ich habe auch Kernel 4.4 & 4.8 & 4.16 ausprobiert (obiger Fehler bei allen Kerneln)

Unten ist meine Systemkonfiguration

enter image description hereHauptplatine

5
Anand Suthar

Wie jemand in den Foren darauf hingewiesen hat ( https://community.AMD.com/thread/228245 ), ist das Skript defekt.

Vorausgesetzt, Sie haben die richtige Kernel- und Header-Version, müssen Sie die fehlenden Pakete manuell installieren. Führen Sie Folgendes aus:

apt install amdgpu-dkms libdrm-amdgpu-amdgpu1 libdrm-amdgpu1 libdrm2-amdgpu  
5
Michele