it-swarm.com.de

Wann wird das neueste Calibre 3 in Ubuntu 16.04 im Software Center verfügbar sein?

Die aktuelle Version 2.55.0 funktioniert bei mir nicht und unterstützt meinen Pocketbook Inkpad 3 E-Book-Reader nicht. Andere Installationsmethoden sind mir zu kompliziert.

3
geras

Aufgrund der Tatsache, dass wir die Freigaberichtlinie in Ubuntu nicht ändern können, erhalten Sie sie wahrscheinlich nicht aus offiziellen Ubuntu xenialen Repositorys.

Sie können jedoch eine der folgenden Methoden verwenden, um die Software zu installieren:

  1. Sie können versuchen, das Kaliber von Jonathon Fs PPA zu installieren.

    Sudo add-apt-repository ppa:jonathonf/calibre
    Sudo apt-get update
    Sudo apt-get install calibre
    

    Dadurch wird Version 3.25 installiert, die neuer als Version 3.21 von Ubuntu Bionic Beaver 18.04 LTS ist.

    Das sieht großartig aus:

    Calibre v.3.21

  2. Sie können auch versuchen, die neueste Version von der offiziellen Website herunterzuladen:

    cd ~/Downloads
    https://download.calibre-ebook.com/3.26.1/calibre-3.26.1-x86_64.txz
    tar -xf calibre-3.26.1-x86_64.txz
    

    und starte es von hier aus mit

    ./calibre
    
  3. Eine andere Möglichkeit ist ein Snap-Paket .

    Derzeit gibt es kein Kaliber-Snap-Paket. Calibre hat eine sehr schöne Benutzeroberfläche, aber Snap ignoriert derzeit die Themes, sodass es nicht besonders hübsch aussieht.

    Und ich habe Zweifel an der Funktionalität dieser Option. Die Snap-Version hat möglicherweise keinen Zugriff auf den USB-Speicher des E-Book-Readers, da ein removable-media Stecker/Schnittstelle fehlt.

    Auch zur Snap-Version kann ich Eli Schwartz (eschwartz) aus zitieren "Feature Request - Package Calibre als Snap-App" Fehlerbericht 1707517 vom 30.07.2017 auf launchpad.net :

    Es gibt bereits einen Cross-Distribution-Tarball, der ohne Snap funktioniert.

    Auch IMHO Snap ist immer noch eine Katastrophe und ich bin sehr dankbar, dass Kovid es nicht benutzt. Er hat Snap schon mehrmals abgelehnt

    https://calibre-ebook.com/download_linux

    duplizieren 1699620

5
N0rbert

Die Antwort ist "nie" (oder eines Tages ...)

Ubuntu 16.04 wurde vor 2 Jahren veröffentlicht. Das Software-Center hält Apps, die getestet wurden, stabil und funktioniert gut mit dieser Version.

Das Software-Center einer neueren Version von Ubuntu, wie zum Beispiel 18.04, die letzte Woche herauskam, hat eine neuere Version von Calibre 3.21.0.

Möglicherweise möchten Sie Ihr Ubuntu in ungefähr 6 oder 7 Monaten auf 18.04 aktualisieren, wenn die Aktualisierungsoption in Ihrem Ubuntu 16.04-System angezeigt wird. Zum Zeitpunkt des Upgrades wird Ihr Calebre auf Version 3.21 aktualisiert. Es bleibt bei dieser Version, bis Sie Ubuntu erneut aktualisieren.

oder eines Tages ...

Die Hersteller von Calibre (oder eine andere Person) können beschließen, ihre Software als Snap-Paket erhältlich für Ubuntu bereitzustellen. In diesem Fall ist Ubuntu 16.04 möglicherweise ab Version 3 verfügbar. Die Art des Snap-Pakets ist so, dass es unabhängig von der Ubuntu-Version automatisch auf die neueste Version aktualisiert wird.

Verwenden Sie bis dahin eine PPA

Ein Personal Package Archive (PPA) ist ein Software-Repository zum Hochladen von Quellpaketen, die von Launchpad als Advanced Packaging Tool (APT) -Repository erstellt und veröffentlicht werden sollen. Wie der Name schon sagt, sind diese persönlich und werden von Ubuntu nicht offiziell unterstützt. Siehe Können PPAs sicher zu meinem System hinzugefügt werden, und worauf sollten Sie achten?

Wenn Sie den PPA verwenden und Clibre 3.21 unter Ubuntu 16.04 zum Laufen bringen möchten, folgen Sie N0rbert's answer und öffnen Sie ein Terminal, indem Sie drücken Ctrl+Alt+T und geben Sie ein:

Sudo add-apt-repository ppa:jonathonf/calibre
Sudo apt-get update
Sudo apt-get install calibre

Oder wenn Calibre bereits installiert ist, ersetzen Sie den letzten Befehl durch:

Sudo apt-get upgrade

Nach dem ersten Befehl werden Sie zur Eingabe Ihres Passworts aufgefordert. Wenn Sie das Passwort in das Terminal eingeben, wird nichts angezeigt und der Cursor bewegt sich nicht. Dies ist normal. Geben Sie das Passwort einfach blind ein und drücken Sie die Eingabetaste. In den folgenden Zeiten werden Sie nicht mehr nach dem Passwort gefragt.

Hoffe das hilft

2
user68186