it-swarm.com.de

VLC wird nicht installiert

Versuch, VLC 16.04 zu installieren

Sudo apt Update Sudo apt installiert vlc

Das bekomme ich

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

 vlc: Abhängig von: vlc-nox (= 2.2.2-5), aber 2.2.4-6 ~ ubuntu16.04.1 ~ ppa1 muss installiert werden 
 Empfiehlt: vlc-plugin-notify (= 2.2.2-5) wird aber nicht installiert 
 Empfiehlt: vlc-plugin-samba (= 2.2.2-5) wird aber nicht installiert 
 E: Nicht möglich Um Probleme zu beheben, haben Sie defekte Pakete in der Hand. 

Vielen Dank für jede Hilfe ...

1
Billn

Dies sind die Lösungen für fehlgeschlagene Installationen von Standardpaketen aus dem Repository.

$ Sudo apt update
$ Sudo apt upgrade
$ Sudo apt install -f
$ Sudo apt install vlc

Die obigen Befehle funktionieren, da sich die Abhängigkeiten tatsächlich im Repository befinden und Sie sicherstellen müssen, dass Sie über die neuesten Updates und Upgrades der Pakete verfügen.

3
L. D. James

Versuchen:

Sudo apt-get update

um deine Paketliste zu aktualisieren. Dann:

Sudo apt-get autoclean

teilpakete zu bereinigen. Dann:

Sudo apt-get clean

den Apt-Cache aufräumen.

Sudo apt-get autoremove

bereinigt alle nicht benötigten Abhängigkeiten. Wenn Sie dabei das beschädigte Paket identifizieren können, wird es durch diesen Code sehr gewaltsam entfernt.

Sudo dpkg --remove -force --force-remove-reinstreq package name

Ändern Sie den Paketnamen natürlich in den richtigen Namen.

Dies wird Ihre defekten Repositories reparieren und dann:

Sudo apt install vlc

installiert vlc für Sie.

1
pearlstar