it-swarm.com.de

Ubuntu 16.04 Software-Updater reagiert nicht. Unvollständige Updates

Ich habe Ubuntu 16.04 Dual mit Windows 10 auf einem HP Laptop gebootet. Der Software-Updater hat die Software aktualisiert. Gegen Ende gab es einen Fehler, blieb hängen und das Fenster reagierte nicht mehr. Es wurde etwas im Zusammenhang mit Perl aktualisiert.

Aber nach langer Zeit habe ich mich entschlossen, den Software-Updater einfach zu schließen. Wenn ich es jetzt erneut ausführe, kann es nicht nach Updates suchen. Wenn ich es schließe, habe ich die Möglichkeit, ein teilweises Upgrade durchzuführen. Dies bedeutet jedoch, dass die exklusive Sperre nicht möglich ist und eine andere Anwendung wie apt-get oder angezeigt wird aptitude läuft und ich muss das schließen. Nach dem Schließen von Sudo apt-get update gibt mir auch etwas Ähnliches. Wenn ich ps -A | grep apt ausführe, erhalte ich zwei Prozesse mit dem Namen aptd. Soll ich diese töten und es erneut versuchen? Wäre das sicher? Gibt es noch etwas, wonach ich in ps -A suchen sollte?

Auch dieses Problem mit dem Software-Updater ist schon einmal aufgetreten. Sogar damals, als es erstarrte, arbeitete es an etwas, das mit Perl zu tun hatte. Könnte es ein Problem mit meinem Software-Updater oder der Perl-Installation geben?

Nach dem Entfernen der Sperrdateien und dem Ausführen von Sudo apt update:

Fetched 188 kB in 1s (122 kB/s)
E: dpkg was interrupted, you must manually run 'Sudo dpkg --configure -a' to correct the problem. 

Ich habe diesen Befehl ausgeführt und Folgendes erhalten: (nach vielen Verarbeitungs- und Einrichtungszeilen)

Errors were encountered while processing:
 shim-signed
 cups
 unattended-upgrades

Die vollständige Ausgabe von Sudo apt upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  iucode-tool libpango1.0-0 libpangox-1.0-0 linux-headers-4.4.0-21
  linux-headers-4.4.0-21-generic linux-image-4.4.0-21-generic
  linux-image-extra-4.4.0-21-generic linux-signed-image-4.4.0-21-generic
Use 'Sudo apt autoremove' to remove them.
The following packages will be upgraded:
  gnome-software gnome-software-common libprocps4 procps ubuntu-software
  update-notifier update-notifier-common
7 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 2,961 kB of archives.
After this operation, 2,048 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 libprocps4 AMD64 2:3.3.10-4ubuntu2.2 [32.7 kB]
Get:2 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 procps AMD64 2:3.3.10-4ubuntu2.2 [222 kB]
Get:3 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 update-notifier AMD64 3.168.2 [48.2 kB]
Get:4 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 update-notifier-common all 3.168.2 [163 kB]
Get:5 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 ubuntu-software AMD64 3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1 [11.7 kB]
Get:6 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 gnome-software AMD64 3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1 [226 kB]
Get:7 http://in.archive.ubuntu.com/ubuntu xenial-updates/main AMD64 gnome-software-common all 3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1 [2,257 kB]
Fetched 2,961 kB in 5s (509 kB/s)                  
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database ... 274520 files and directories currently installed.)
Preparing to unpack .../libprocps4_2%3a3.3.10-4ubuntu2.2_AMD64.deb ...
Unpacking libprocps4:AMD64 (2:3.3.10-4ubuntu2.2) over (2:3.3.10-4ubuntu2) ...
Preparing to unpack .../procps_2%3a3.3.10-4ubuntu2.2_AMD64.deb ...
Unpacking procps (2:3.3.10-4ubuntu2.2) over (2:3.3.10-4ubuntu2) ...
Preparing to unpack .../update-notifier_3.168.2_AMD64.deb ...
Unpacking update-notifier (3.168.2) over (3.168.1) ...
Preparing to unpack .../update-notifier-common_3.168.2_all.deb ...
Unpacking update-notifier-common (3.168.2) over (3.168.1) ...
Preparing to unpack .../ubuntu-software_3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1_AMD64.deb ...
Unpacking ubuntu-software (3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1) over (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) ...
Preparing to unpack .../gnome-software_3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1_AMD64.deb ...
Unpacking gnome-software (3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1) over (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) ...
Preparing to unpack .../gnome-software-common_3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1_all.deb ...
Unpacking gnome-software-common (3.20.1+git20160923.2.7374bdc-0ubuntu1~xenial1) over (3.20.1+git20160617.1.0440874.ubuntu-xenial-0ubuntu1~16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu4) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (229-4ubuntu12) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for gconf2 (3.2.6-3ubuntu6) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for libglib2.0-0:AMD64 (2.48.1-1~ubuntu16.04.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Setting up libprocps4:AMD64 (2:3.3.10-4ubuntu2.2) ...
Setting up procps (2:3.3.10-4ubuntu2.2) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
Setting up cups (2.1.3-4) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package cups (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up shim-signed (1.19~16.04.1+0.8-0ubuntu2) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

secure boot

2
Sss
  1. Öffnen Sie software-properties-gtk und deaktivieren Sie die automatischen Updates
  2. Überprüfen Sie, ob APT ausgeführt wird, indem Sie: ps ax | grep apt verwenden, und verwenden Sie dann kill -9 .., oder wenn dies fehlschlägt kill -2 ...
  3. Schlösser entfernen

    Sudo find /var/lib/apt/ /var/lib/dpkg/ -iname lock -exec rm {} \;
    mkdir ~/backup; Sudo mv /var/cache/debconf/*dat* ~/backup/
    
  4. Beenden Sie die letzte Installation mit.

    Sudo dpkg --configure -a
    Sudo apt -f install
    
  5. Führen Sie das Update zur Überprüfung aus

    Sudo apt update 
    Sudo apt upgrade
    Sudo apt dist-upgrade
    
  6. Öffnen Sie software-properties-gtk und aktivieren Sie die automatischen Updates

0
user.dz