it-swarm.com.de

Qualcomm Atheros QCA6174 802.11ac Wireless-Netzwerkadapter [168c: 003e] (Version 32) kann WLAN nicht aktivieren

Ich habe gerade Ubuntu 16.04 LTS (Kernel-Version 4.8.0-36-generic) auf einem neuen Notebook mit Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32) installiert und es funktioniert nicht.

Ich habe die Lösung im Internet gefunden, aber sie funktioniert bei mir nicht. Das habe ich getan:

  1. von diesem Repository heruntergeladene Treiber: https://github.com/kvalo/ath10k-firmware

  2. diese Treiber wurden in das Verzeichnis /lib/firmware/ath10k/QCA6174 kopiert

  3. Sudo cp /lib/firmware/ath10k/QCA6174/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1 /lib/firmware/ath10k/QCA6174/firmware-4.bin

  4. neu laden

Aber Wi-Fi funktioniert immer noch nicht. Wenn ich versuche, WLAN in den Einstellungen zu aktivieren, kann ich das nicht tun.

Dies ist die Ausgabe des Befehls dmesg | grep ath10k:

[   10.040200] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   10.548072] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[   10.548079] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[   10.591818] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[   10.591823] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[   10.592326] ath10k_pci 0000:02:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 5 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
[   10.820021] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 07ee144e
[   12.984484] ath10k_pci 0000:02:00.0: htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   13.587814] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0
[  215.900218] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[  216.178456] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[  216.178465] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[  216.178507] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
[  216.178509] ath10k_pci 0000:02:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
[  216.178713] ath10k_pci 0000:02:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[  216.178715] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[  216.179486] ath10k_pci 0000:02:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
[  216.243352] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 07ee144e
[  218.410241] ath10k_pci 0000:02:00.0: htt-ver 3.26 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[  218.498078] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0

Dies ist lshw Ergebnis:

   *-network DISABLED
        description: Wireless interface
        product: QCA6174 802.11ac Wireless Network Adapter
        vendor: Qualcomm Atheros
        physical id: 0
        bus info: [email protected]:02:00.0
        logical name: wlp2s0
        version: 32
        serial: 58:00:e3:f6:bd:6f
        width: 64 bits
        clock: 33MHz
        capabilities: bus_master cap_list ethernet physical wireless
        configuration: broadcast=yes driver=ath10k_pci driverversion=4.8.0-36-generic firmware=WLAN.RM.2.0-00180-QCARMSWPZ-1 latency=0 link=no multicast=yes wireless=IEEE 802.11
        resources: irq:320 memory:94000000-941fffff

Ich habe auch versucht, dies zu tun:

Sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

Sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board.bin?raw=true

Sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board-2.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/board-2.bin?raw=true

Sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/kvalo/ath10k-firmware/blob/master/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

Aber das Ergebnis war das gleiche.

Ich kann nicht verstehen, was ich falsch mache.

P.S. Entschuldigung für mein Englisch )

UPD:

rfkill list all Ausgabe:

0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
2: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
4: phy1: Wireless LAN
    Soft blocked: no
    Hard blocked: no
5
Kirill

Führen Sie in einem Terminal

Sudo tee /etc/modprobe.d/ideapad.conf <<< "blacklist ideapad_laptop"

und neu starten.

Und ich schlage vor, nicht mit der Firmware zu fummeln. Stellen Sie auch das Standardpaket von wieder her

 Sudo apt update
 Sudo apt install --reinstall linux-firmware

Sie müssen mit dem Internet verbunden sein, um dies zu tun.

4
Pilot6

Weil Sie uns gezeigt haben, dass der Befehl "rfkill list all" Folgendes beinhaltet:

0: ideapad_wlan: Wireless LAN Soft blockiert: nein Hard blockiert: ja

Ein "harter Block" ist, wenn ein physischer Aus-Schalter aktiviert ist. Manchmal gibt es physische Schalter, die sich nach links oder rechts bewegen, um ein Modul zu aktivieren, oder es ist eine F-Taste oder eine Funktionstaste + F, die das Modul aktiviert.

Finden Sie heraus, welches Gerät für Ihren Computer geeignet ist, und schalten Sie es um. Überprüfen Sie dann erneut "rfkill list all" und prüfen Sie, ob der Hard-Block weg ist. Es sollte "Fest blockiert: Nein" heißen.

1
user735319