it-swarm.com.de

Problem beim Installieren von Oibaf

Ich versuche, Oibafs PPA für Mesa auf dem Computer meiner Frau zu installieren. Wir arbeiten beide mit 15.10 und auf meinem Computer hat es ohne Probleme funktioniert, aber auf ihrem scheint es, als wäre es beim Rendern von Software hängen geblieben. Auf ihrem Computer sagt mir glxinfo:

glxinfo | grep OpenGL renderer
OpenGL renderer string: Gallium 0.4 on llvmpipe

Während auf meinem:

OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 2.43.0, LLVM 3.6.2)

Wir haben zuvor fglrx verwendet und ich habe versucht, sie mit den Anweisungen zu löschen hier . Unser Problem scheint ähnlich zu sein wie llvmpipe loswerden. Open Source-Treiber korrekt installieren aber mit der vorgeschlagenen Methode zur Installation von Oibaf hat es nicht funktioniert:

Sudo apt-get install ppa-purge
Sudo ppa-purge ppa:oibaf/graphics-drivers
Sudo reboot

Sudo add-apt-repository ppa:oibaf/graphics-drivers
Sudo apt-get update
Sudo apt-get upgrade
Sudo reboot

Das Xorg.0.log scheint jedoch zu behaupten, dass noch Reste von fgrlx herumhängen:

[    44.489] (==) Matched fglrx as autoconfigured driver 0
[    44.489] (==) Matched ATI as autoconfigured driver 1
[    44.489] (==) Matched modesetting as autoconfigured driver 2
[    44.489] (==) Matched fbdev as autoconfigured driver 3
[    44.489] (==) Matched vesa as autoconfigured driver 4
[    44.489] (==) Assigned the driver to the xf86ConfigLayout
[    44.489] (II) LoadModule: "fglrx"
[    44.489] (WW) Warning, couldn't open module fglrx
[    44.489] (II) UnloadModule: "fglrx"
[    44.489] (II) Unloading fglrx
[    44.489] (EE) Failed to load module "fglrx" (module does not exist, 0)

Ich habe gerade aufgegeben, also brauche ich wirklich ein paar Vorschläge, was falsch sein könnte. Funktioniert Oibaf nicht mehr für 15.10, daher sollte ich auf 16.04 upgraden? Das ist ein Übergang, an den ich sowieso denke, aber ich würde es vorziehen, die Grafiktreiber in der richtigen Reihenfolge zu haben, bevor ich eine Änderung vornehme, die mich davon abhält, zu fgrlx zurückzukehren.

Edit: Ich habe mich für ein Upgrade auf 16.04 entschieden und danach sah es tatsächlich so aus, als wäre Oibaf installiert. Ein paar Verpackte hielten sich aus irgendeinem Grund zurück, aber ich zwang sie durch

Sudo apt-get dist-upgrade

Ich habe neu gestartet, aber glxinfo zeigte immer noch llvmpipe. Ich habe versucht, den Anweisungen zu folgen hier gemäß dem Vorschlag aus dem Kommentar unten, aber es hat nicht geholfen.

2
Skadlig

Mit der Hilfe von Bridgman in den Phoronix-Foren konnte ich herausfinden, dass das Problem der Kernel war

[    32.211] (II) [KMS] drm report modesetting isn't supported.
[    32.211] (EE) open /dev/dri/card0: No such file or directory[/CODE]

"nomodeset" wurde in grub gesetzt, um den Kernel daran zu hindern, es für sich selbst herauszufinden. Das habe ich gemacht:

Sudo vi /etc/default/grub

Suchen Sie die Zeile "GRUB_CMDLINE_LINUX_DEFAULT", entfernen Sie den Nomodeset und speichern Sie ihn.
Aktualisiere grub und starte neu.

Sudo update-grub
Sudo reboot
3
Skadlig